Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo

installation failed while building mysql db schema


Go to End


1490 Views

Avatar
liug

Community Member, 1 Post

27 May 2008 at 8:10am

I am trying to install silverstripe-v2.2.2 on my fedora 8 box.
I have the latest mysql 6.0.4 from http://dev.mysql.com/downloads/mysql/6.0.html

Installation of SS failed with the below errors. Is there a quick workaround to make silverstripe work with mysql 6.0? Thanks!

PHP Fatal error: DATABASE ERROR: Couldn't run query: CREATE TABLE `Newsletter` (\n\t\t\t\tID int(11) not null auto_increment,\n\t\t\t\t`ClassName` enum('Newsletter') character set utf8 collate utf8_general_ci default 'Newsletter',\n`Created` datetime,\n`LastEdited` datetime,\n`Status` enum('Draft','Send') character set utf8 collate utf8_general_ci default 'Draft',\n`Content` mediumtext character set utf8 collate utf8_general_ci,\n`Subject` varchar(255) character set utf8 collate utf8_general_ci,\n`SentDate` datetime,\n`ParentID` int(11) not null default '0',\nindex `ParentID` (ParentID),\nindex `ClassName` (ClassName),\n\n\t\t\t\t\n\t\t\t\tprimary key (ID)\n\t\t\t) TYPE=MyISAM | You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'TYPE=MyISAM' at line