Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo

Problems upgrading from 2.2.1 to 2.2.2


Go to End


2 Posts   1185 Views

Avatar
nomen

Community Member, 52 Posts

4 June 2008 at 1:18am

Edited: 05/06/2008 4:05am

Hi all:
I try to upgrade a web from SS 2.2.1 to 2.2.2.
I follow this document to upgrade.

The problem is when i make http://your.silverstripe.site/db/build?flush=1. It deletes all new page types that i have created,and converts the pages with this page type to "Page".
Here is part of the log:

# Changed 152 rows to default value of field ClassName (Value: 'Page')
# Field SiteTree.ClassName: changed to enum('SiteTree','GhostPage','Page','UserDefinedForm','ErrorPage','RedirectorPage','VirtualPage','SiteMap','SubscribeForm') character set utf8 collate utf8_general_ci default 'SiteTree' (from enum('SiteTree','Page','UserDefinedForm','SubscribeForm','ErrorPage','GhostPage','RedirectorPage','VirtualPage','EspeciesPage','NewsHolder','NewsLinkPage','NewsPage','ProductPage','SiteMap') character set utf8 collate utf8_general_ci default 'SiteTree')

I´m doing something bad?

Avatar
nomen

Community Member, 52 Posts

4 June 2008 at 8:09pm

Edited: 05/06/2008 4:05am

Here is the file of the db/build results.