Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo

mod_rewrite / SSViewer error...

Go to End

11 Posts   6036 Views


Community Member, 17 Posts

7 May 2007 at 1:06pm

Edited: 07/05/2007 1:08pm

Andy -

Thanks for getting back to me. So would the only edit be changing the 'delete' to 'unlink'? I did do that and got past the error, but I still wind up with my error stating...

mod_rewrite doesn't appear to be working. Make sure:

* mod_rewrite is enabled in your httpd.conf
* AllowOverride is enabled for the current path

And, after I force it I still get the 21 instances of the /~username/ in the URL. Do you have any notion of why that might be happening? Do you think this is something that is specific to the host that I am with? Their help docs state that mod_rewrite is enabled (

Thanks for your help.


Community Member, 17 Posts

9 May 2007 at 5:52am

Edited: 09/05/2007 5:54am

Andy -

Just to let you know, I was able to replace the files yesterday with the newest daily build (5-7), and then had to put in the alternative rewrite rule - as explained here - and then the installation was finally a success!!!

My only simple question right out of the gate do I edit the 'header' title and subtitle within the cms, without having to grab and edit the (code) page itself? It wasn't readily apparent. Note: this is within the new 'black candy' theme that's packaged in the installation.

Thanks for the help so far; I'm sure I'll have other questions as I move along, but at least the installation issue is resolved.



Community Member, 2 Posts

29 May 2007 at 5:22am

I got a similar error using a daily build version. Here's what I've discovered...

I'm on hostgator, which supports PHP 4 and 5. PHP 5 has to be called from a domain ( vs. and the back end package, cPanel, has a feature that allows you to choose between PHP 4 and 5.

However, the .htaccess file for PHP4 includes the number 4 in the statement. The PHP 5 statement does not include the "5" ... so the server itself, if you use the built in tweak, certainly knows that you're requesting PHP5, but Silverstripe's default is to assume you're running 4 if it doesn't see the "5"...

I assume this is why the daily builds tend to generate multiple iterations of .htaccess.

I won't tell you how many times I tried installing this... over a period of days... using various builds. I have high hopes for this package and was determined to get it to work.

The errors were being attributed in the forums to PHP5 issues. I knew it had to be a language barrier... and I suspected .htaccess.

I decided to start over one last time:

1. obliterate all files -- all vestiges of silverstripe
2. delete the MySQL database, user and link (create a new set with all new names)
3. manually edit the .htaccess file at your web root to remove all silverstripe commands (otherwise, when you try to reinstall you get the "this seems to have been installed already!")

I wanted a complete Mulligan. The ultimate do-over.


1. I grabbed a fresh copy of the stable release (not the nightly builds that resolved some problems only to create others) and uploaded it to the server.
2. created a new database/user/and linked them using cpanel's MySQL management ... again, new names.
3. went to the and added (a.) the database details and (b.) an admin email and password ... which is incredibly easy to miss? That's why there are so many people who can't login after installing...

Got green lights and a little worried orange over the apache mod rewrite, but had already found and tested "rewritetest.php" in my browser and knew it was working.

Once the install was over? I got a dreadful error message. SSViewer... something.

It didn't really matter what it said.

I looked at .htaccess. Silverstripe had re-written my .htaccess file and had removed the PHP 5 statement altogether. ??

I manually edited .htaccess to add two lines of code -- calling PHP5, and calling it by number right at the top:

AddType x-mapp-php5 .php
AddHandler application/x-httpd-php5 .php

above the line:

RewriteEngine On

Once I did that? I went to the root of my domain and got a happy login.
Whew! Now I can play.

This won't solve everyone's problem but I know it will solve someone's problem so I will not have lived in vain.

Go to Top