Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo

Set start Language


Go to End


9 Posts   4520 Views

Avatar
vispi

Community Member, 3 Posts

2 July 2008 at 9:02pm

Hello,

how can i set a new standard Language for user in a multilanguage environment?

via ?lang=de and ?lang=en works, but on first visit its english not german?

i18n::set_default_lang('de'); // for German not work

Kind Regards

Avatar
cliersch

Community Member, 75 Posts

3 July 2008 at 1:45am

Hi vispi,
try this in the mysite/_config.php
i18n::set_locale('de_DE');
setlocale (LC_ALL, 'de_DE@euro', 'de_DE', 'de', 'ge');

but...
...does anybody knows how to change the meta tag content language
<meta http-equiv="Content-Language" content="en">

I couldn't find any settings how to switch the content language.

Avatar
cerelac

Community Member, 34 Posts

3 July 2008 at 5:10am

Edited: 03/07/2008 5:10am

Hi.

vispi, try putting this in your "_config.php" file:

 i18n::enable(); 
i18n::set_default_lang('de_DE');

tiga, I think that if you use this code in your native language, your problem will be solved.

Best Regards

Avatar
vispi

Community Member, 3 Posts

3 July 2008 at 6:53pm

hi,

_config.php includes now

i18n::enable();
i18n::set_default_lang('de_DE'); // for German
i18n::set_locale('de_DE');
setlocale (LC_ALL, 'de_DE@euro', 'de_DE', 'de', 'ge');
HTTP::set_cache_age(0);

But Visit Start-Languageare english and CMS Languages now German (Germany) = English Version and German = German Version.

<meta http-equiv="Content-Language" content="de"> not work.

Best Regards

Avatar
cerelac

Community Member, 34 Posts

3 July 2008 at 9:12pm

vispi, try removing this code in your "_config.php" file:

 setlocale (LC_ALL, 'de_DE@euro', 'de_DE', 'de', 'ge');
HTTP::set_cache_age(0); 

Best Regards

Avatar
cliersch

Community Member, 75 Posts

4 July 2008 at 1:11am

Thank you cerelac! That works perfectly :-))

Avatar
vispi

Community Member, 3 Posts

4 July 2008 at 1:54am

sorry, but it's not work.

_config.php:

i18n::enable();
i18n::set_default_lang('de_DE');
i18n::set_locale('de_DE');

Content was english but Security/login = German?

Strange.

Avatar
cerelac

Community Member, 34 Posts

4 July 2008 at 3:41am

vispi, I forgot to tell you to remove this line:

 i18n::set_locale('de_DE'); 

Best Regards

Go to Top