Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo

was the image upload problem fixed?

Go to End

4 Posts   2041 Views


Community Member, 22 Posts

9 July 2008 at 9:33pm

Edited: 09/07/2008 9:34pm

I tried searching for this, but it's a little hard to find forum posts by date so I don't know what the latest news is on this bug.

A few months ago it was virtually impossible to get the image upload tool to work properly...images would appear in the directory, but then you couldn't get them to appear in folders so you could insert them into your content. (Not talking about hard-coding things into templates, just the usual drag & drop).

I've been away for a while but am looking to get back into SS... has this been fixed?


Community Member, 22 Posts

10 July 2008 at 5:19am

Looks like swfupload was disabled in 2.2.2. - found it in this thread:

Going to try out 2.2.2 today! :)


Community Member, 22 Posts

10 July 2008 at 5:44am

Looks like I spoke too soon. Honestly, I'm extremely impressed with Silverstripe and it's my favorite CMS I've tested in the last year (and there have been many...way too many).

But two things, the swf image upload issue and the 1-2 second delays in load times in the admin & frontend (that have been well documented) are causing me to look for another CMS option.


Forum Moderator, 5523 Posts

10 July 2008 at 9:45am

Yes the SWF issue has been removed in 2.2.2 - It was just nasty and it never worked at all for me. The speed issue as you said is well noted and speed improvements are being done for the next release.

As for the issues upgrading to 2.2.2 with the modules, It does appear that most have some issues as the latest releases for the modules are all quite out of date - released before 2.2.2. The best thing I can recommend is you try the trunk / latest daily build versions of each of the modules as these are more likely to work with 2.2.2