Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo

admin email and password does not work

Go to End

10 Posts   11356 Views


Community Member, 78 Posts

10 July 2008 at 12:42am

I cannot log in to the admin page on one of my sites but have not changed the username or password. Why is this so?
One thing i did notice when i was last in it is that is said i was logged in as "yihy hijythir" or something similar, rather than "admin"!
At the time I was logged into the admin and in another window I was just testing a UserDefinedForm and in the email feild put something like "yihy hijythir" just to fill it in.
Could this have changed the email for the login!?
How can i reset or change the login details?


Community Member, 78 Posts

10 July 2008 at 12:49am

Edited: 10/07/2008 12:50am

If i use admin and password i do not get the green box saying that i am not using the right email and password but if i try it with a different email and the same password it does!?


Forum Moderator, 5523 Posts

10 July 2008 at 10:01am

How can i reset or change the login details?

Do you have access to the db or something like phpmyadmin to manage it? What you can do is view the members table - remove all the members (should only be admin) and then you can visit to recreate the admin / password account. But this only works if there is no users in the system currently


1 Post

21 July 2008 at 2:51am

I'm having the same issue. Created a new site, added admin/admin user password, but cannot login.

I've tried to empty the Members table and call /db/build?username=admin&password=admin, but no new record is created in the Members table.


Forum Moderator, 5523 Posts

21 July 2008 at 12:14pm

strange if that didnt work. You might need to reinstall it.


Community Member, 17 Posts

10 August 2008 at 3:54pm

willr - tried your advice, it worked :) thanks!



Community Member, 12 Posts

15 August 2008 at 2:24am

This worked for me too. So yah as willr said remove all records from members table and then make sure your site is set to development mode in the mysite config file. Then run


Community Member, 105 Posts

25 September 2008 at 12:43pm

Edited: 25/09/2008 12:54pm

How the heck do you set the thing to development in the config file?

DO NOT FOLLOW THE ADVICE ABOVE!!!!!!! *danger Will Robinson danger*

F*CK! Think I just lost *EVERYTHING*

I am really beginning to hate Silverstripe.

Go to Top