Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo

add external files


Go to End


7 Posts   2778 Views

Avatar
satpal

Community Member, 13 Posts

10 July 2008 at 2:28am

can anyone tell me how can i add an external file like html file ,.js etc in silverstripe

Avatar
dio5

Community Member, 501 Posts

10 July 2008 at 2:34am

Could you explain a bit more?

for adding in a js file you can generally do something like this in your Page_Controller init():

Requirements::javascript ("mysite/javascript/myjsfile.js");

see: http://doc.silverstripe.com/doku.php?id=requirements

For including html, not sure what you mean, normally html goes into the templates...

Avatar
microcarl

Community Member, 4 Posts

21 September 2008 at 11:19pm

Edited: 21/09/2008 11:20pm

what if i want to add an external Javascript file like the google maps file?

Requirements::javascript("http://maps.google.com/maps?file=api&v=2.x&key=....");

doesnt work because it generates code like this:

<script type="text/javascript" src="http://sandbox.micromusic.org/http://maps.google.com/maps?file=api&amp;v=2&amp;key=..."></script>

Any help appreciated!

Avatar
dio5

Community Member, 501 Posts

22 September 2008 at 7:58pm

You can always put it in the template...

Avatar
microcarl

Community Member, 4 Posts

22 September 2008 at 8:54pm

Edited: 22/09/2008 8:55pm

so there is no way to add an external script in the code? like with

Requirements::...
??

right?

i just saw that in the "maps" module all google script have been included like this and didnt work (of course). or can i configure something that paths to JS starting with "http://..." arent linked relatively? but maybe i have to aks & tell the "google map module" people about it.

thanks dio5 for your help!

Avatar
dio5

Community Member, 501 Posts

22 September 2008 at 9:03pm

Edited: 22/09/2008 9:05pm

Are u sure it really doesn't work, or something else might be causing this?

I'm using the maps module as well on a site of mine and didn't have any problems with that.

Avatar
microcarl

Community Member, 4 Posts

22 September 2008 at 9:50pm

yes, i tried it yesterday and it always created this useless tags (check src attribute):

<script type="text/javascript" src="http://mydomain.com/http://www.google.com/....">

what SS version did you use? i used a pretty new checkout from the SVN. maybe that's the problem because something changed lately in the SVN code? strange anyway.