I need to change the name of a page type from one that is generated from the class name to a more sensible one. How can I do this? I've tried setting the $add_action of the page type class, but it doesn't help.
p.s. I mean the name that is displayed in the "create" dropdown