Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo

No response from admin address

Go to End

6 Posts   1332 Views


Community Member, 5 Posts

1 August 2008 at 11:41pm

I asked this question on IRC, but nobody replied:

After adding some ordinary page and publishing it, admin stopped working. There is absolutely no response on ?isDev=true displays no error message. By writing echo 'hello'; I tracked down where the problem lies and I inserted debug_backtrace there. It's

/srv/www/hosts/, Objekt: SSViewer, Funkce: process
/srv/www/hosts/, Objekt: CMSMain, Funkce: renderWith
:, Objekt: CMSMain, Funkce: RightBottom
/srv/www/hosts/, Objekt: , Funkce: call_user_func_array
/srv/www/hosts/, Objekt: CMSMain, Funkce: cachedCall
/tmp/, Objekt: CMSMain, Funkce: hasValue
/srv/www/hosts/, Objekt: , Funkce: include
/srv/www/hosts/, Objekt: SSViewer, Funkce: process
/srv/www/hosts/, Objekt: CMSMain, Funkce: defaultAction
/srv/www/hosts/, Objekt: CMSMain, Funkce: run
/srv/www/hosts/, Objekt: , Funkce: direct

where script silently dies on line "include($cacheFile);". This drives me mad, I have no idea on how to fix it.


Community Member, 5 Posts

5 August 2008 at 12:56am

I tried to solve this problem again, this time considering silverstripe as a black box, i.e. define outside conditions under which the bug occurs.

1. Problem is only observed on production server, therefore I suppose some magical server settings is causing this.
2. If (number_of_page_types + number_of_pages_in_site_tree) > x, admin stops working.

Where x=20 in my case. Yes, it's so ridiculously absurd. If I delete a page from the Site tree, I can add one page type and vice versa. If it's not so fucking serious, it would be funny.

I tried to verify again backtrace from my first post, but it's simply not possible. Including of temporary files and usage of attribute overloading makes ss undebugable. Now I'm thinking about "not enough memmory" reason, but I think that ss has some protection against memmory shortage state (does it?). And I'm progressing realy slowly, please someone help me...


Community Member, 5 Posts

5 August 2008 at 1:01am

I had to send previous post twice, because when I send it first time, I got some php fatal error. I can't describe enough, how much I don't like ss:).


Community Member, 5 Posts

5 August 2008 at 3:21am

I finaly solved it. The memory limit is 32M on production server which is too low. For unknown reasons the server didn't display a single word when it abnormaly terminated the script.

To sum it up: When you have server with memory limit 32M, you can't have too many (20) pages and/or page types on your site with SilverStripe. This is a very bad joke.


Community Member, 904 Posts

5 August 2008 at 3:53am

Edited: 05/08/2008 3:54am

Hi. Well, at least you figured out what the Problem was ;)
Maybe you should file this in the bugtracker?

I figure memory handling can be quite tough in PHP. You can query the amount of memory that is currently being used (memory_get_usage). But where to actually place this in your code (or the SilverStripe code) is the tough question.
Maybe you could gracefully quit the application by implementing a custom error handler.. but who knows if it would still be called when running out of memory.

At least it's good to know about this issue/limitation.


Community Member, 5 Posts

5 August 2008 at 9:50pm

I'm not asking for memory shortage warnings from inside the code, it's almost imposible and it's webmaster's job anyway. Maybe I'm too old fashioned, but few years ago 32MB was enough to run the whole operating system and now it's not enough to generate a single webpage with Silverstripe? I definitely have to be doing something wrong, otherwise SS is one of the worst CMS I have ever seen. By the way, having templating system based on a hundreds ereg_replace lines and applying it on many kilobytes-sized files in a single run is insane.

P.S. When I post something on this forum and it takes more than about 10 minutes to write it, I get:
Fatal error: Call to a member function setField() on a non-object in /sites/ssopen/www/forum/code/Forum.php on line 647
Isn't it funny?:)