Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo

problem with insert counter to the site


Go to End


4 Posts   1633 Views

Avatar
WebSpilka

Community Member, 89 Posts

7 August 2008 at 10:34pm

Edited: 07/08/2008 10:35pm

I register on the http://top.bigmir.net/counters/ (id=16794891)
And get counter HTML code
When I add the code in the template page.ss
On the Site I see next

Помилка синтаксичного аналізу XML: неправильний 
Адреса: http://planeta-ua.net.ua/ 
Рядок 213, символ 100:<a href="http://www.bigmir.net/" target="_blank"><img src="http://c.bigmir.net/?v16794891&s16794891&t2" width="88" height="31" alt="bigmir)net TOP 100" title="bigmir)net TOP 100" border="0" /></a>
---------------------------------------------------------------------------------------------------^

Avatar
Willr

Forum Moderator, 5523 Posts

7 August 2008 at 10:44pm

it is because the & in the URL of that code isnt valid xhtml. It needs to be &amp; to be valid.

Avatar
WebSpilka

Community Member, 89 Posts

8 August 2008 at 12:21am

but when I write instead

&
=>
&amp;

then the counter does not load on homepage
((
counter must be at the bottom of page

Avatar
Willr

Forum Moderator, 5523 Posts

8 August 2008 at 10:13am

well if &amp; doesnt work then you can try sending the page as not strict xml - removing the <? xml... bit at the top of the Page.ss file. This will stop SilverStripe sending the template as 'pure' xml (which is the most strictest)