Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo

Sudden install errors out of nowhere

Go to End



Community Member, 1 Post

13 October 2008 at 10:34pm

Edited: 13/10/2008 11:07pm


So last week I downloaded SilverStripe and was able to install it without any errors what so ever, I created a small website and got to show it to my client just fine. Well, almost... Half way into my walkthrough of the system showing my client the features of this CMS, I was going to show the login screen because he was wondering how that part worked. So I logged out just fine, but there's the part where the problems came. The page it showed as the login screen, was the class, with the text from the login screen interestingly enough. No login form or anything. So I was literally locked out of the CMS.

So I got to work this morning and figured I'd start over to fix the problem. No luck there. I'm not even able to get it working anymore. Not even from a clean database and download.
The installation process says nothing. No errors or anything. It's exactly the same as when I installed it last week and it worked straight away. But after the installation it's far from what it should be. I've attached a screenshot of what I get right after installing.

The server I'm running it on is WAMP, working as my local development server.

Anyone have any ideas? Because I'm clueless.

Edit: Forgot to say, if I go to http://localhost/fubi instead of http://localhost/fubi/ (Note the additional forward slash) I get the folderview instead, listing all files. Oh and when I got to work and was about to reinstall, I noticed all important files in the main folder were missing (index.html, index.php and so on). Weird huh?

Edit 2: I hate these things.. Now it's suddenly working for some reason, after doing nothing to it.. Well, hope it doesn't decide to stop working again.. <knocks on wood>

Edit 3: Okay so I found out why the login form was missing before. I had changed to my liking and also removed "$Form" from it.. Apparently that HAS to be in there for you to be able to log in... Something I didn't find about in the documentation...