Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo

SS installation worked for 3 months - now php error

Go to End

2 Posts   1011 Views


Community Member, 23 Posts

15 October 2008 at 10:45pm

Our Silverstripe installation has stopped working after 3 months of being ok with the following error

Parse error: syntax error, unexpected T_STATIC, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or '}' in /home/makin26/public_html/silverstripe/sapphire/core/ManifestBuilder.php on line 35

having looked in the forums this error has occurred on installation sometimes and once to someone who had a site working for 6months but there is no instructions on how to solve the problem

php 5 is installed on the server so this isn't the problem


Community Member, 23 Posts

15 October 2008 at 11:21pm

I solved this with help from SS IRC

my webhost had turned off php5 but it still showed as enabled in the hosting control panel.

I checked the running version of php by placing a file calling phpinfo() into the root folder.

This showed that, somehow, the version of php had changed to 4.4.9 yet the control panel still showed php5 enabled?!

Resetting php5 in the control panel got the site going again