Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo

Problem installing because of the database name


Go to End


5 Posts   1620 Views

Avatar
al5976

Community Member, 6 Posts

24 October 2008 at 11:03pm

My web host requires that I have the database set-up with the following web223-name

When I try to install SS, SS changes this to web223name in the set-up and then can't find the database. Is there a way around this?

Avatar
al5976

Community Member, 6 Posts

25 October 2008 at 1:46am

Edited: 25/10/2008 1:47am

If I can't install it via the installer how do I do it via shell?

Avatar
mschiefmaker

Community Member, 187 Posts

28 October 2008 at 3:12pm

Try writing the datasbase name directly into the install.php file. This shoul stop it from dropping the dash

Cheers

MM

Avatar
al5976

Community Member, 6 Posts

29 October 2008 at 5:40am

Hi,

Thanks for the reply, That helped, it's now accepting the database name - but never gets past this stage:

Installing SilverStripe...

I am now running through the installation steps (this should take about 30 seconds)

If you receive a fatal error, refresh this page to continue the installation
# Creating 'mysite/_config.php'...
# Creating /home/sites/smirthwaite.co.uk/public_html/mysite/_config.php
# Creating '.htaccess' file...
# Creating /home/sites/smirthwaite.co.uk/public_html/.htaccess
# Building database schema...

I have checked the details all correct....Any ideas?

Thanks

Avatar
al5976

Community Member, 6 Posts

29 October 2008 at 6:27am

I have just been through about twenty different Posts where peple have failed on the same place

# Building database schema...

Most of the posts are from last year so probably not relevant. I have tried load of the tips in them but still not getting past that stage. Is there an SQL dump I could use to try and get the site up and running?