Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo

Unable to login to the CMS


Go to End


9 Posts   3297 Views

Avatar
bonafidemike

Community Member, 1 Post

9 November 2008 at 6:14am

I just installed Silverstripe on my Apache web server. Everything seemed to install fine, and I chose my admin username/password during the install. Now, from the new home page, I click the link to "open the CMS", where it takes me to what I assume is the admin login. However, it's asking either for an e-mail/password, or an OpenID; neither of which was asked for during the installation.

How do I login to start creating my web site, with the username/password I chose during the installation? :-(

Avatar
Liam

Community Member, 470 Posts

9 November 2008 at 6:45am

During the install it does ask you for your email address and password. This is used for the admin login - domain.com/admin/

If you filled it out as just a username/password, that is also fine. Try using those details in the login form where it says email address. Don't worry about the openID stuff.

Worst case scenario, delete and do a fresh install and pay closer attention, however it will work with the username you picked instead of a email address.

Cheers,

Avatar
vish

Community Member, 4 Posts

22 November 2008 at 12:48am

I am sorry , if i sound redundant...

but I am not able to log in to "The CMS" page mysite/admin by using my login details...I have just finished a fresh install of silverstripe 2.2.3 on the server and I have no clue why is it behaving the way it is...

any help would be greatly appreciated! :)

Avatar
Fuzz10

Community Member, 791 Posts

22 November 2008 at 2:40am

try the default admin/password

otherwise you can stick a fixed admin-login in the _config.php

Refer to :
http://doc.silverstripe.com/doku.php?id=configuration

for the necessary info.

Avatar
vish

Community Member, 4 Posts

22 November 2008 at 4:18am

I tried the default settings, no use :(

_config.php seems to be flying all over my head... i did add the 'Security::setDefaultAdmin(’admin’,’password’)' line in it but now d login page doesn't come at all

I am a newbie to hard coding

Thanks for ur help..in anticipation :)

Avatar
Fuzz10

Community Member, 791 Posts

22 November 2008 at 4:29am

You added the configuration line without the start and end quote I hope ? ;-)

Avatar
vish

Community Member, 4 Posts

22 November 2008 at 5:01am

below are the contents of my _config.php file:
pl. suggest wat can be done... currently it just says for anything that the email address or password is wrong... i have tried using an actual email address instead of the admin username but in vain...

<?php
/**
* URL rules for the CMS module
* @package cms
*/
Director::addRules(50, array(
'processes/$Action/$ID/$Batch' => 'BatchProcess_Controller',
'silverstripe' => '->admin',
'cms' => '->admin',
'admin/statistics/$Action/$ID' => 'StatisticsAdmin',
'admin/security/$Action/$ID/$OtherID' => 'SecurityAdmin',
'admin/help/$Action/$ID' => 'CMSHelp',
'admin/newsletter/$Action/$ID' => 'NewsletterAdmin',
'admin/reports/$Action/$ID' => 'ReportAdmin',
'admin/assets/$Action/$ID' => 'AssetAdmin',
'admin/comments/$Action' => 'CommentAdmin',
'admin/ReportField/$Action/$ID/$Type/$OtherID' => 'ReportField_Controller',
'admin/bulkload/$Action/$ID/$OtherID' => 'BulkLoaderAdmin',
'admin/ImageEditor/$Action' => 'ImageEditor',
'admin/$Action/$ID/$OtherID' => 'CMSMain',
'unsubscribe/$Email/$MailingList' => 'Unsubscribe_Controller',
'PageComment/$Action/$ID' => 'PageComment_Controller'
));

Security::setDefaultAdmin(’admin’,’zzzzzzz’)

?>

this is the _config.php file from .../cms folder

Avatar
vish

Community Member, 4 Posts

22 November 2008 at 5:13am

the line says :

Security::setDefaultAdmin(’admin’,’zzzzzzz’);

and now d page appears but the end result is still the same...painful :(

Go to Top