Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo

Install problem - still need help

Go to End

3 Posts   1203 Views


Community Member, 16 Posts

13 November 2008 at 9:34am


I cannot get SS to install on my ISP's server. I keep getting a parse error connected to manifestbuilder.

On the install page, I get messages that SS can't tell what my webserver is and can't tell if mod_rewrite is enabled. If I click install it goes through the motions, populates the database and then gives me a message that mod_rewrite is not working.

I have tried linking to two other databases (not on same system), same problem. My ISP tells me that the php.ini commands in SS need to be tweaked (whereever they maybe on the software). I have no direct access to the root server, only have access to the MySQL admin. I have tried other CMSs and they install no problem.

Prior to the above issue I had to insert a htaccess file (the info came from my ISP) pointing to PHP 5. Here it is:
AddType x-mapp-php5 .php
AddHandler x-mapp-php5 .php
Is this okay?

I've already posted about this issue, still not giving up: Here's the post:

Any ideas, guys?


Community Member, 712 Posts

13 November 2008 at 10:40am

What exactly is the error?

Also, can you provide a phpinfo page?



Community Member, 16 Posts

13 November 2008 at 11:33am

Hi Hamish,

Just popped in a phpinfo page (am afraid I am not savvy enough to make much sense of it)

I downloaded the latest version of SS (2.2.3)

The error starts on the install page. PHP configuration is okay, file permissions are okay, but webserver is 'orange' with errors about 'server software' (message: I can't tell what webserver you are running. Without Apache I can't tell if mod_rewrite is enabled.) and 'mod_rewrite enabled' (Message: I can't tell whether mod_rewrite is running. You may need to configure a rewriting rule yourself.)

Click install and it then stops with this message: ERROR: mod_rewrite not working, redirecting to mod_rewrite test page.

This then gives me a new page with:

mod_rewrite doesn't appear to be working. Make sure:
mod_rewrite is enabled in your httpd.conf
AllowOverride is enabled for the current path.
Please check these options, then refresh this page.If you believe that your configuration is correct, click here to proceed anyway.

I click proceed anyway and this gives me:

Parse error: syntax error, unexpected T_STATIC, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or '}' in /homepages/0/d68570838/htdocs/sprachlernstrategien/mysite/sapphire/core/ManifestBuilder.php on line 35

I talked to my ISP and they say it's the software. I don't have access to the directories of the root server for the database except via the usual database name/host/password. Silver Stripe does successfuly populate the database, so it can write to the database.

The provider is 1&1 in Germany and I found this article referring specifically to 1&1 and the same problem. But the solution didn't work for me (could be I did something wrong, though, not sure when I should pop in the htaccess file)

Any ideas?