Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo

forum error


Go to End


3 Posts   1715 Views

Avatar
introvert

Community Member, 2 Posts

21 November 2008 at 8:09am

Edited: 21/11/2008 8:09am

Hello.

I downloaded and install the module forum. After I added it to my website and publish the default General Discussion topic I get the following error when I go to my website and click on this topic:

XML Parsing Error: junk after document element
Location: http://silverstripe/general-discussion/
Line Number 2, Column 1:<b>Notice</b>:  Controller::currentController() is deprecated. Use Controller::curr() instead. in <b>C:\www\vhosts\silverstripe\sapphire\core\control\Controller.php</b>; on line <b>367</b><br />

Any idea what is going on?

Avatar
marcin

Community Member, 5 Posts

21 November 2008 at 8:48pm

Hi,

Open /forum/code/Forum.php and replace line 155 with:

$controller = Controller::curr();

instead of:

$controller = Controller::currentController();

and it works fine.

Marcin

Avatar
bebabeba

Community Member, 193 Posts

2 December 2008 at 11:45pm

I have your same problem and I found solution to download latest version here:
http://dailybuilds.silverstripe.com/modules-tarballs/