Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo

Blank Pages When Deployed

Go to End

7 Posts   2104 Views


Community Member, 9 Posts

29 November 2008 at 5:15pm

I'm attempting to deploy a SilverStripe website to a server. I have it running on my local machine with no problems, and have also deployed it to another server without any trouble. Unfortunately this particular server is causing me trouble. When I attempt to load the website (any page) I just receive a "blank page" ie. an empty response.

Here is what I have tried so far:

1. Verified that mod_rewrite is enabled and tested with a standalone script.
2. Confirmed that .htaccess is working correctly.
3. Tested the exact files and database on local and another external server.
4. Tested the database connection (DB name, username, password).
5. Put the site into 'dev' mode, still no errors displayed.

I'm using SilverStripe 2.2.2 and the server I'm attempting to run it on uses PHP 5.1.6. Could this be a problem? Unfortunately I don't have access to the server's error logs at this time. It appears that the request goes to Sapphire correctly and the database connection is fine, but nothing is returned.

Any suggestions on a possible cause or other areas to check would be greatly appreciated!

Thank you,
Mike Wheaton


Community Member, 9 Posts

30 November 2008 at 2:48pm

No one has a suggestion for what to try next? I'm completely stuck here, but this must be something that someone has come across before.


Community Member, 470 Posts

30 November 2008 at 5:04pm

Put it in debug mode to see if any errors appear. In your config file



Forum Moderator, 5523 Posts

30 November 2008 at 6:21pm

The apache / php error logs are really the place to start. On this server have you installed a basic version of silverstripe with the installer to pick up any issues before trying to deploy?


Community Member, 9 Posts

1 December 2008 at 6:23am

Even in debug mode no errors are displayed.

I tried to install a basic version of SilverStripe and it stopped on install.php after displaying 'Building database schema...". No tables are ever created in the database.

The only issue shown on the first install page is:
Check that the php.ini setting allow_call_time_pass_reference is on

Any suggestions?


Community Member, 18 Posts

2 December 2008 at 3:09am

Just experienced the same problem. From my error log:

Permission problem gaining access to a temp folder. Please create a folder named silverstripe-cache in the base folder of the installation and ensure it has the correct permissions

Did the trick for me!


Community Member, 9 Posts

2 December 2008 at 6:23pm

Thanks for the suggestion, Richie. Unfortunately the silverstripe-cache folder didn't help and I haven't found anything useful in the server logs. We may have to use a different server, I suppose.