Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo

inconsistently breaking

Go to End

9 Posts   6536 Views


Community Member, 6 Posts

4 July 2007 at 5:44pm

Edited: 04/07/2007 5:44pm

Hi there,

having got my hosting providers to install SilverStripe for me (they needed to temporarily increase the memory allocation, install it and then decrease the memory allocation again) the site works fine. However when I click the "go to the CMS" link it throws up:

Fatal error: Class 'SiteTree' not found in /home/iwihost/ on line 3

I refreshed and eventually the CMS admin loaded, and I could edit and make changes, and safe a draft and publish. When I visited the page again however, I refreshed to see the new changes and they were there but when I tried clicking on the link to go to the admin it throws that error again.

I don't know how or why it works sometimes, but it's certainly frustrating.

any ideas?


Forum Moderator, 628 Posts

5 July 2007 at 6:06pm

Edited: 05/07/2007 10:42pm

Sorry to hear you're having trouble..

What version of PHP you running?

I assume you've run /db/build ?


Community Member, 6 Posts

9 July 2007 at 10:38am

alas, i tried very hard to get silverstripe up and running, but in the end too much time was being devoted to something we just couldn't get working. i'm pretty sure it was partly to do with the hosting provider, as we could install it fine locally using WAMP, but at the end of the day if we can't get it to run we can't get it to run. i've moved to drupal, but i'll definitely keep an eye on silverstripe as it develops.



Community Member, 201 Posts

9 July 2007 at 12:10pm

Hi Lee,

Can you tell us the name of the web host you were using so we can save other people any future frustrations using that host?

Please reply here or update this page;


Community Member, 37 Posts

11 July 2007 at 3:45am

I tryed to install in Powweb servers but got errors, Powweb`s support told me that SS could´nt be installed on theyr servers for security reasons, that´s all I got from them.


Community Member, 201 Posts

11 July 2007 at 9:59am

Thanks I've added them to the list..


Community Member, 6 Posts

12 July 2007 at 8:51am


yes, the host is webdrive --

to their credit they helped enormously -- they upped the amount of allocated resources specifically for us so we could install without getting any errors, they gave us access to all the correct services etc.

The problem is -- I would recommend these guys to anyone. So I'm left feeling that if Silverstripe didn't use quite so much RAM we would have been able to make it work (as we did locally).


Community Member, 37 Posts

13 January 2008 at 10:40pm

Update: shared servers do work, they just need a bit more effort to get running as they are setup differently :-)
I have a couple of personal sites running fine thanks to:
(also see an update of this on

I have added a ticket to hopefully solve these issues with the webdrive shared server so others won't have this problem in the future.

Go to Top