Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo

Mapping/Forum to go on demo soon


Go to End


15 Posts   3293 Views

Avatar
Sigurd

Forum Moderator, 628 Posts

17 July 2007 at 1:46pm

Edited: 17/07/2007 1:49pm

Ofir ...? Still waiting on this...

I also noticed that in the ForumMemberMap that you should allow the username to link to their member profile, i.e.

<a href="$Link To Member Profile"> $Username </a>

Avatar
Sigurd

Forum Moderator, 628 Posts

18 July 2007 at 1:57pm

Ofir, you timed out on this so I went ahead and coded it myself.

I found lots of files where you needed global $GMaps_API_Key;

I also updated the Member Map so that you can click on a member and navigate to their profile:

<a href=\"ForumMemberProfile/show/'.$member->ID.'\">'.$member->Nickname.'</a>

This is now tagged in:
svn://svn.silverstripe.com/silverstripe/modules/maps/tags/0.11

And available at
http://www.silverstripe.com/assets/downloads/modules/maps-0.11.tar.gz

I've updated http://www.silverstripe.com/silverstripe-modules/

Avatar
Sigurd

Forum Moderator, 628 Posts

18 July 2007 at 2:31pm

Alrighty, just doing final steps and the demo.silverstripe.com will be updated ! :)

Avatar
Sigurd

Forum Moderator, 628 Posts

18 July 2007 at 3:00pm

... and its up.

Let me know if you find any issues (make sure you ctrl-refresh as CSS/JS has changed)

Avatar
Sigurd

Forum Moderator, 628 Posts

18 July 2007 at 3:17pm

Found two things
a) The newsletter system won't send out newsletters as no template is set up (This is really an issue with v2.0.2, which should have created a default template)
b) The FlickrGallery doesn't show the lightbox when viewed in Safari3-- Lakshan can you please track down why?

Avatar
Markus

Google Summer of Code Hacker, 152 Posts

18 July 2007 at 7:24pm

Edited: 18/07/2007 7:24pm

I don't like that under the forum member map there is automatically written "Forum Users" (http://demo.silverstripe.com/member-map/).

I didn't looked at the code if this is hard coded, but I logged in and it appears nowhere.. so I guess it's hard coded.

In my opinion that "label" should be removed because I think most of the time the label doesn't make sense at all since every page has normally a title.

Avatar
elijahlofgren

Google Summer of Code Hacker, 222 Posts

19 July 2007 at 5:11am

> a) The newsletter system won't send out newsletters as no template is set up (This is really an issue with v2.0.2, which should have created a default template)

In the gsoc branch it seems that templates are no longer required to send out Newsletters, which is nice I guess. ;)

Go to Top