Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo

Installer Problems

Go to End

8 Posts   3782 Views


Community Member, 33 Posts

24 January 2007 at 1:53pm

Hi All

Trying to install on Fedora Core 5 server running apache 2.2.2, php 5.1.6, mysql 5.0.27. GD and mbstrings are installed. Unpacked into a folder under /var/www/html and group set to apache.

The installer gives me lots of php notices as shown by sample below. Under the notices is the html page that i was expecting to see.
*Notice*: Use of undefined constant mysql - assumed 'mysql' in
*/var/www/html/silverstripe/install.php* on line *11*

*Notice*: Use of undefined constant SCRIPT_FILENAME - assumed
'SCRIPT_FILENAME' in */var/www/html/silverstripe/install.php* on line *395*

*Notice*: Undefined offset: 3 in
*/var/www/html/silverstripe/install.php* on line *405*
<!--many lines snipped-->

The mysql boxes show <br> tabs in the text boxes, but will install the database if I put appropriate setting in the boxes .

Install appears to complete, but then says there is no "sucessinstall.php" file.


Why is there a check for a variable "mysql" very early in install.php? My phpinfo() does not show such a variable and I have never seen it before. Is it intended to check that mysql is installed?

Are these php5 problems and the installer has been set for php4?



Community Member, 85 Posts

24 January 2007 at 4:01pm

A quick solution to fix the many 'Notice' errors you're receiving is to turn off E_NOTICE warning-level messages in PHP. All of the error messages you're seeing are caused by things you can safely ignore. They'll be fixed in the next release of the installer, but until then, open up install.php and add the following line just after the first line (<?):
error_reporting(E_ALL ^ E_NOTICE);

The other errors (<br /> tags in input boxes) will also be fixed in the next release. Thanks for reporting them.


Community Member, 33 Posts

25 January 2007 at 9:54am

Thanks Matt

Unfortunately I am still not able to install. The installer runs, and then tries to access "[BASE_DIR]/home/successfullyinstalled". However the installer has not generated this file. I have done a global search to see if it has been put somewhere else, but have not been able to find it. I have also set [BASE_DIR] and subdirectory permissions to owner=apache and group=apache to ensure that the webserver will not have any problems writing files.
The database appears to have been correctly written.



Administrator, 690 Posts

25 January 2007 at 11:15am

Hi Ken,

The system isn't supposed to generate a file called home/successfullyinstalled.

Instead, it adds a rewrite rule to a .htaccess file that points all unrecognised URLs to sapphire/main.php?url=XXX

SilverStripe manages the site's URLs itself.

It's possible that the .htaccess file isn't being correctly interpreted by Apache. Do you have mod_rewrite included, and is your server configured to allow RewriteRule and RewriteEngine in .htaccess files?


Community Member, 33 Posts

25 January 2007 at 12:14pm

Ah! Success!

I have not used local .htaccess files on my server before, so had to install an AllowOverride directive in httpd.conf for this site. I am now able to access the home page.

Now on to the next stage :)

Thanks guys


Community Member, 33 Posts

5 February 2007 at 11:28pm

I am continuing to have problems with this CMS. I have successfully installed v2.0 beta, but cannot get v2.0 to install. I have now tried to put the cms live on my webserver. I am using a name-based virtual server and everything else works.

I am getting error messages from the server suggesting that I increase the value of LimitInternalRecursion. I increased to 100 and still getting the same error.

I have installed Silverstripe in a subfolder under /var/www/html/ eg /var/www/html/client

my httpd.conf has the following

<VirtualHost ip_address:80>
UseCanonicalName off
DocumentRoot /var/www/html/client
<Directory /var/www/html/client>
AllowOverrides All

My DNS server is set up correctly

I then get a 500 Internal Server Error
The webserver log says "Request exceeded the limit of x internal redirects due to probable configuration error. Use "LimitInternalRecursion" to increase the limit if necessary.

Help! I am getting very frustrated with this CMS!



Community Member, 33 Posts

7 February 2007 at 12:21pm

Edited: 07/02/2007 12:22pm

Thanks Sam

For others following this discussion,

my .htaccess had a
RewriteRule .* /client/sapphire/main.php..........

We changed this to
RewriteRule .* /sapphire/main.php......

and it now works fine.