Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo

Problem when uploading an image (image field).

Go to End

4 Posts   6913 Views


Community Member, 791 Posts

18 July 2007 at 8:23pm

Edited: 18/07/2007 8:24pm


I just found a problem when uploading an image through an image field.

Situation :
- Added an image-field to my article type (for thumbnail use)
- The field shows up correctly in the backend
- When uploading an image from my local hard-drive , it will upload the file correctly , but the iFrame will not redirect correctly (page not found error in IE , in FireFox it will just be blank).
- After refreshing the page , everything works perfectly.

See screenhots below :


Community Member, 791 Posts

24 July 2007 at 12:43am

Edited: 24/07/2007 12:46am

I found another little bug in the backend which has to do with the Image CMS Field.

Replace or add an existing image through the CMS interface, pick "with one from the file store" but don't choose anything in the dropdown (just leave "(choose)") .. press "attach image" or "replace" and you'll get :

Fatal error: Call to undefined method stdClass::write() in /var/www/sites/ on line 401


Community Member, 2 Posts

23 October 2008 at 12:57pm

Edited: 23/10/2008 12:57pm


Did you manage to find a solution for this issue?

I'm frustrated right now, as it worked perfectly on my test server (a copy of my live server).

But now I have deployed the webste it's not working anymore.

I hope someone can help with this



Community Member, 2 Posts

24 October 2008 at 1:20am

Problem SOLVED!!!!!!!!!!!

The problem was basically a permission restriction.
All images uploaded through the ecommerce modules get resized, thus they need to be put in the _resampled folder.
Since in my case the _resampled folder had (CHMOD 775). Appearantly that wasn't enough and I couldn't change it.

So I created a new folder in the Uploads root and called it _resampled2 (with CHMOD 777)
Then I deleted the original _resampled folder
And then re-named my _resampled2 to _resampled

Now it's working perfectly