Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo

Cant Install Silverstripe

Go to End

13 Posts   26355 Views


1 Post

26 July 2007 at 1:14am

Hello! I am trying to install Silverstripe on my hosted site. When I point my browser to the default Siverstripe folder on the server I get..

Call to undefined function: posix_getpwuid() in /home/content/j/v/i/jvvvv/html/silverstripe-v2.0.2b/install.php on line 307

I can install Joomla no problems so I guess my environment should be OK?

Any Tips?




Forum Moderator, 628 Posts

26 July 2007 at 1:33am

It seems you don't have posix installed, which is odd... it is a normal php module enabled by default.


Administrator, 690 Posts

28 July 2007 at 8:20am

You can get around this by editing install.php and making the function that calls posix_getpwuid() just return true.

It will mean that the installer won't be able to check if your file permissions are okay.


5 Posts

28 July 2007 at 3:26pm

I had a hangup with Godaddy, then i checked the PHP settings and found it by default was set for PHP 4. The work around was to open open the ".htaccess" file at the root of the install and add the following:

AddHandler x-httpd-php5 .php
AddHandler x-httpd-php .php4

Save it back in the root in the Silverstrip folder. I added a copy of this file to this post.

Then I closed the browser and waited for the cache to recycle (roughly every hour they reset at and installed perfectly. One more thing you might check is that it is MySQL 5.0 vs. 4.1. They give you options for both, but by default is 4.1.

I hope that can help you along.


Community Member, 10 Posts

1 September 2007 at 4:58pm

Edited: 01/09/2007 4:59pm

I seem to be having the same problem at with my hosted account. I have made the change to .htaccess in the root directory, but I am still getting the same error.

Should I have copies of .htaccess elsewhere in the file tree?

I will try to make the change to the install.php to return true, but I am not a php expert, so any advice on how to do this would be helpful.




Community Member, 10 Posts

1 September 2007 at 6:05pm

Edited: 02/09/2007 5:05am

Sorry, posted twice. See new post in Bugs..


12 Posts

7 February 2008 at 12:55pm

Here is a full write up for installing SS on Godaddy:


Community Member, 1 Post

7 February 2008 at 3:46pm

I followed the steps in the above given link but i am still getting the HTTP 404 not found error. This is what my .htaccess file looks like:

AddHandler x-httpd-php5 .php
AddHandler x-httpd-php .php4
RewriteEngine On

RewriteCond %{REQUEST_URI} !(\.gif)|(\.jpg)|(\.png)|(\.css)|(\.js)|(\.php)$
RewriteCond %{REQUEST_URI} ^(.*)$
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule .* /sapphire/main.php?url=%1&%{QUERY_STRING} [L]

I've silverstripe folder in my root directory. I would appreciate if someone could help me with this, thank you!

Go to Top