Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo

Install fails silently on creating database schema

Go to End

7 Posts   2190 Views

Design City

38 Posts

29 August 2007 at 7:18pm

Edited: 29/08/2007 7:20pm

Hi Guys,

First up, i'm really looking forward to creating my first SilverStripe site. I've used a few CMSs in the past, but none of the open source CMSs are really what i'd call production quality - you can run a fan site or a club site fine on Joomla, but when it comes to a corporate site that needs to be flexible and easy to use at the same time, most of the solutions have let me down. SilverStripe seems to be the right mix or ease of use and flexibility that a professional needs!

On to my reason for posting - an installations problem.

I get the following once I try to install Silverstripe:

Installing SilverStripe...

I am now running through the installation steps (this should take about 30 seconds)

If you receive a fatal error, refresh this page to continue the installation 
Creating 'tutorial/_config.php'...
Creating '.htaccess' file...
Building database schema...

...Then nothing. Having a look around I see that opening "http://DOMAIN.COM/db/build?flush=1" can be of some help troubleshooting-wise, and this is the error I get:

Fatal error: Cannot access protected property Director::$environment_type in /cust-web/i/e/I1323352/sites/DOMAIN.COM/html/sapphire/core/control/Director.php on line 331

Any ideas on where I go from here or even what I might search for in Google? (yep, I'm that lost!)

Much appreciated guys :)


Community Member, 231 Posts

30 August 2007 at 10:24am

Well you can solve this by changes the line

static protected $environment_type;


static public $environment_type;

at about line 338 of Director.php. It sounds like you have an older version of PHP, I would advise updating if possible - you may run into other issues.

Design City

38 Posts

5 September 2007 at 4:12pm

My PHP version is 5.2.1 - You're right Andy, I'm running into other problems!

I ended up bypassing my installer problems and just uploaded a finished site from my local machine - no more problems with $environment_type.

There's obviously still a problem, I'm now presented with the follwoing error:

Fatal error: Class 'ReflectionClass' not found in /cust-web/i/e/client/sites/ on line 215

I'd really like to _not_ have to ask the client to move servers for their new site - anything that makes the process seem more complicated is never a good thing for a layperson. Is there a fix for this error, or am I going to have to bite the bullet and move to another host?


Forum Moderator, 922 Posts

6 September 2007 at 9:43am

I assume you've tried ?flush=1 already?


Design City

38 Posts

6 September 2007 at 1:05pm

Edited: 06/09/2007 1:08pm

Yep, thanks Sean, tried ?flush=1 and even gave /db/build?flush=1 a go...

What's really strange on this server (other servers i've installed silverstripe on are fine) is that I keep getting different errors. Each time I fire up the browser I get a new error - this morning's was:

Fatal error: Cannot access protected property Object::$classConstructed in /cust-web/i/e/client/sites/ on line 97

So following Andy's advice, I changed 'public' to 'protected' for $classConstructed as well, and now I get nothing - no error, silverstripe just fails to load :(

Design City

38 Posts

19 September 2007 at 4:05pm

Edited: 19/09/2007 4:07pm

Adding to my installation woes on this server is the following when I try to install 2.1 rc1 - however I'm pretty sure it was the same error with 2.02b:

<h1>Installing SilverStripe...</h1>
<p>I am now running through the installation steps (this should take about 30 seconds)</p>
<p>If you receive a fatal error, refresh this page to continue the installation
<li>Creating 'mysite/_config.php'...</li>
<li>Creating '.htaccess' file...</li>
<li>Building database schema...</li><br />
<b>Fatal error</b>: Class 'ReflectionClass' not found in <b>/cust-web/i/e/I1323352/sites/</b> on line <b>246</b><br />

Any SS'ers know what might be causing this?



Community Member, 3 Posts

12 November 2008 at 2:50am

Edited: 12/11/2008 2:56am

This happens regardless of the version if you don't have the reflection php option enabled when compiling php.

I had the issue with 2.2.3 and i found the solution here:

On the short, check to make sure you are compiling PHP with support for reflection, either by setting the correct compilation flags or by ensuring you don't set the --disable-reflection when compiling.

Also, for other issues that don't seem to relate to user classes you might want to check if those classes are not part of php, enable them and recompile php (if you can afford to do that)..


later edit: and don't forget to restart apache before you make another attempt at installing silverstripe.