Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo

Fatal Errors during Install

Go to End

2 Posts   1808 Views


Community Member, 10 Posts

2 September 2007 at 4:46am

Edited: 02/09/2007 6:13am

Hello All:

Summary of Configuration:
Shared hosting with
MSSQL 5.0.45
PHP 5.1.4
Apache 1.3.33

Fatal Error 1 (solved): Received an Fatal Error upon initially trying the install, realized that I needed to manually create the Assets folder (wasn't part of the install package)

Fatal Error 2 (Still open): Made it to the first install screen, sees the dbase, looks like everything should be OK. Just one thing listed in orange:

a) Can't confirm the mod_rewrite

Here is what I get on the next screen after hitting Install:

Installing SilverStripe...
I am now running through the installation steps (this should take about 30 seconds)

If you receive a fatal error, refresh this page to continue the installation

Creating 'mysite/_config.php'...
Creating '.htaccess' file...
Building database schema...
Fatal error: Object::__call() Method 'pushCurrent' not found in class 'Controller' in /home/content/m/p/u/mpuich/html/sapphire/core/Object.php on line 190

I tried the refresh, but doesn't work.

Any ideas what is going on? I have configured my host to be PHP 5, for all php extensions. So, any help would be appreciated.




Community Member, 10 Posts

4 September 2007 at 7:04am

Ok. So, I am learning .php on the fly, and tried to find the push_current function in the referenced objects at that step in Install.php, but couldn't find it any either Object.php, Controller.php, or ViewableData.php.

So, I commented the command referring to push_current, and it seems to have installed.

What I am afraid happened is that when I was running into a previous install issue with the 2.0.2b main build (needed to manually create the assets directory), I installed a newer build of install.php. This seems to have a command that references this push_current function, and I didn't update all of my install files with the most recent builds (maybe it is there somewhere in the newer version of those other files.)

Anyway, seems to be working, at least for now.