Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo

Fatal error: Call to undefined method stdClass::allMethodNames()

Go to End

3 Posts   2170 Views


28 Posts

10 September 2007 at 6:06am

This is in the daily builds 2007-09-07 and 2007-09-09, I don't know about
other versions of the daily build.

The daily build installs ok, and I can access the cms.
However when I copy cms,jsparty, and sapphire to a working directory
(build 2.0.2-rc2), do a database rebuild and then attempt to access the
cms from the overlaid directory I get:

"Call to undefined method stdClass::allMethodNames() in /var/www/html/s/sapphire/core/Object.php on line 203"

The daily build version works ok, it just fails when I try to overlay an existing version.
I assume that something in the new version's database has changed and has to be
updated in the old database which the overlaid version is still using.
The overlaid site still works, I just get this error when attempting to login to the
cms so I can't administer the overlaid site.

When will 2.0.3 be released and will there be a way to change/update the database
so the existing site information will not have to be manually renetered?
In the meantime is there something I can do manually?


Community Member, 231 Posts

11 September 2007 at 1:12pm

2.1.0 will be released shortly, not much longer to wait. :) The database can be upgraded by visiting , there shouldn't be any issues keeping your content.


28 Posts

11 September 2007 at 2:30pm

Thanks for the info about the release. I see it now on the main page.

I still get the error even after doing a "s/db/build?flush=1".

I have tried the following where "s" is the working directory and
"s.20070909" is a renamed silverstripe.2.0.DailyBuild.2007.09.09"
cd s
rm -rp cms jsparty sapphire
cp -rp ../s.20070909/cms .
cp -rp ../s.20070909/jsparty .
cp -rp ../s.20070909/sapphire .
http://localhost/s/db/build?flush=1 (from a browser)
I have done this on a untar'd s.20070909 and also aftering
doing an install on the s.20070909 directory