Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo

Installing SS - issues with PHP 5.2.0?

Go to End

6 Posts   2767 Views


Community Member, 39 Posts

15 February 2007 at 9:40am

Edited: 15/02/2007 9:50am

Hey there guys, long time listener, first time caller....

So yeah, got the old install of SS 2, and have uploaded to a test server.

The install file immediatly came up with...

Fatal error: Out of memory (allocated 524288) (tried to allocate -1 bytes) in /usr/home/atech/domains/ on line 303

so, after sam looked at it, and nate (the server host) looked at it, he downgraded php to 5.1.6 and it worked!

Now, I have set up the MySQL database, but its still comnig up with an error regarding the version of MySQL..

Check it out at

<link removed>

the php info can be found at

<link removed>

Help on this would be appreciated - heres an email from nate:

I just couldnt help myself, i had to poke further about the mysql errors which u cant get rid of......

unless you comment out this line in the install.php script

#$this->requireMySQLVersion("4.1", array("MySQL Configuration", "MySQL version at least 4.1", "MySQL version 4.1 is required, you only have ", "MySQL " . mysql_get_server_info()));

To me it looks like its trying to check it twice or some wack shit, but
yea, anyways doing that seems to fix0r the problem and installs fine

hmm i should probably do some work

Anywho, talk to u on msn when u surface :)



Administrator, 690 Posts

15 February 2007 at 9:48am

Someone else complained that the installer was mis-detecting the version of MySQL installed. As long as you've got MySQL 4.1 installed, commenting out that line should be fine.

We'll get the installer patched for a 2.0.1 release.


Community Member, 39 Posts

15 February 2007 at 9:49am

thanks - your avatars smile instills me with confidence.


Community Member, 1 Post

21 March 2007 at 10:05am

I get the exact same error message using OS X 10.4.8 and XAMPP 0.6.1 (see my post in the install/download area forum).
Thank you for the tip with downgrading to PHP 5.1. With xampp it is easy to switch between PHP4 and 5, but downgrading to PHP 5.1 is not easily possible as far as I know. After many days of (finally successfully) installing the TYPO3 CMS on OS X, I am not willing to embark on another hacking odyssey! Come on guys, can't you provide your software compatible with the recent PHP versions?


Community Member, 3 Posts

21 March 2007 at 1:06pm

Hi there,

Just went to try this and got
"MySQL version 4.1 is required, you only have .."
This was on 4.1.9 (I think) so I upgraded to 5.2 and it picked up the SQL version fine on the first load of install.php, but as soon as I put in my DB details it reverted back to the error above.

Just a FYI as I already read you are fixing the installer in the next release.



Community Member, 2 Posts

20 April 2007 at 5:42am

I am using PHP 5.2.1 with the same initial error on Apache 2.2 on OSX 10.4, installed through macports:
Fatal error: Out of memory (allocated 524288) (tried to allocate -1 bytes) in /Users/Nate/Documents/work/cms/svn-repos/trunk/silverstripe/install.php on line 302

The solution for me was to change the owner of the files and directories of silverstripe to www. Thought this might help someone in the future.