Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo

My Host is saying "your CMS software is exhausting the 20MB limit on the server "

Go to End

3 Posts   2131 Views


16 Posts

20 September 2007 at 11:50pm

full comment back from my host is

"It does appear that your CMS software is exhausting the 20MB limit on the server due to trying to carry out too many processes. We would recommend contacting the software vendor to advise is a provedure to prevent this error from happening."

I told them about this error I was recieveing on install of silverstripe.

"Allowed memory size of 20971520 bytes exhausted (tried to allocate 140 bytes)" (The script was running its data object test when it got this error).

this is stopping the install from completing, Is what my host is saying true? and what can I do to get around this problem?

Thank you for any help.


Forum Moderator, 801 Posts

21 September 2007 at 2:20am

this is not an "error" in a strict sense, just a requirement that silverstripe has (32MB minimum):

on the short term, there's really nothing we can do about this. some hosters allow you to disable some php-extensions to free up more ram per process, though - you might want to check back with your hoster on this.


16 Posts

21 September 2007 at 2:41am

Edited: 21/09/2007 2:45am

Haa, so it is just the mem set in php.ini

It says in the install check that it needs a min of 20mb but recommends 32mb.

If I could get them to increase the memory while it installs then reduce back down to 20mb would it work ok, or will it 'spaz' out all the time?

Regards david

Ignore post just tested and it brings up same error. you may want to edit your install check, to say that it requires 32mb min.

I will have to have a nice little word with the host to see if they will increase it for me... I have a feeling there are not going to play ball.. My fault should have gone for a tried and tested host.. lesson learnt!!

Cheers guys