Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo

SS rc2.1.0 rc2 testing

Go to End

4 Posts   1340 Views


53 Posts

24 September 2007 at 9:35pm

Edited: 24/09/2007 9:59pm


Sorry to report this but still having problems with save & publish.

I've installed completely fresh version and new database on local machine.

When I change any content I can save, but then when I click save & publish I get the red box error at the bottom that says "Error publishing content".

Also if I make changes and don't click save first but go straight for save & publish I get the same error.

I then tried to create a complete new page and get the same result so can't add any content.

I ran db/build?flush=1 to clear eveything down but got the same.

Let me know if there is any further information I can provide to track this down.




Community Member, 231 Posts

25 September 2007 at 9:58am

If you install firebug (, you can see the response of ajax request in the firebug console, that may give an indication of what's going wrong.


53 Posts

25 September 2007 at 7:39pm

response header

ERROR:Error 256: Object::__call() Method 'publish' not found in class 'Form'
At l190 in /Applications/MAMP/htdocs/
user_error(Object::__call() Method 'publish' not found in class 'Form',256)
line 190 of Object.php
line of
line 175 of Controller.php
line 53 of Director.php
line 101 of main.php

I will try and track down but I'm new to php so any pointers or thoughts appreciated.


53 Posts

25 September 2007 at 9:10pm

problem solved, sorry must have been me!

I started again from scratch rather than copying over an existing folder and all is working mustn't have overwritten or something sorry about that.