Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo

Installer stops at, "Building database schema..."

Go to End

11 Posts   32880 Views


2 Posts

12 October 2007 at 11:36pm

I'm really wanting to try out this CMS but everytime I run the installer it stops:

Installing SilverStripe...

I am now running through the installation steps (this should take about 30 seconds)

If you receive a fatal error, refresh this page to continue the installation
# Creating 'mysite/_config.php'...
# Creating '.htaccess' file...
# Building database schema...

Afterwords if I try and go to the site I either get redirected to the install.php, which says that it's already installed but I can reinstall over it, or I get an error page like this:


The website server has not been able to respond to your request.

The installer says everything checks out "OK" so I have no idea what's wrong. If I delete the MySQL database it does create it again but it doesn't populate the database with anything.


Forum Moderator, 5523 Posts

14 October 2007 at 7:24pm

add this to the _config.php file in the Mysite Folder - Director::set_environment_type("dev"); this will output a more useful error message rather then just error.


2 Posts

17 October 2007 at 5:34pm

Edited: 17/10/2007 5:35pm

I can't seem to get the error page back again, each time I try and install it just stops at the same part, "Building database schema." Then if I try and visit the index it redirects me to the install.php and asks me to install it again. The way I got the error I think was when I tried installing it locally and then importing the database and uploading the files.

When the installer runs it's able to create the database if it's not there but it never creates any of the tables or populates the database with anything before it stops.


3 Posts

8 November 2007 at 10:14am

Edited: 08/11/2007 9:28pm

Hi, I have the same problem. Installation stops on "Building database schema...". Any ideas are very welcome.


Community Member, 4 Posts

12 March 2008 at 5:01am

I am also getting the same error. I tried adding the 'dev' setting, but dont see any errors. It just stops. I do have enough memory, but am running PLesk 8.3. Any help appreciated.


Community Member, 1 Post

16 May 2008 at 6:21pm

Hi all,

Had the same issue as this... turned out to be an issue with MySQL and the mod_rewrite I think... Here's what I did to get past the stopping at "Building database schema" bit.

1. Uploaded software to host as per normal.

2. Uploaded a new .htaccess to my webroot with the following content:

RewriteEngine On
Options -MultiViews

RewriteRule \.js$ - [L]
RewriteRule \.css$ - [L]
RewriteRule \.png$ - [L]
RewriteRule \.jpg$ - [L]
RewriteRule \.gif$ - [L]
RewriteRule \.php$ - [L]

RewriteCond %{REQUEST_URI} ^(.*)$
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule .* sapphire/main.php?url=%1&%{QUERY_STRING} [L]

php_flag zend.ze1_compatibility_mode Off


3. Attempted to run the installation again and this time I started receiving errors about the mod_rewrite not being configured correctly.

4. Clicked continue to ignore the errors and continue with the installation

5. Installation appeared to be successful but only got a blank page so I went to (mysite)/db/build?flush=1 which showed that the db was being correctly created.

6. Went to and still just a blank screen, so then I loaded that with the url

7. Went to and logged in. Clicked each of the pages in the CMS and clicked on the "Save and Publish" button for each.

Once this was done I was up and running...

Hope this might help others.


Community Member, 20 Posts

7 September 2008 at 4:36pm

I have tried replacing the .htaccess file with a new file containing the text suggested above and it is not helping. I still get the error:

Fatal error: Class MySQLQuery cannot extend from interface Query in / on line 452

(I've replaced my URL with "")

I also cannot figure out how to turn on extra debugging. Everything in the install check script seems to indicate that my site is ready for the installation. Please advise.

Nexus Rex

Community Member, 8 Posts

20 November 2008 at 9:17pm

I have this same problem as well, and the proposed solution above did not change anything. Database tables are never created.

There must be somebody out there who has figured this out by now.

Travis Cable

Go to Top