Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Blog Module /

Discuss the Blog Module.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

XHTML 1.1 Validation


Go to End


1371 Views

Avatar
PhilB

Community Member, 1 Post

4 January 2010 at 12:40pm

Edited: 04/01/2010 12:49pm

Hi Guys

I'm in the process of building my first site using SilverStripe (nice work, by the way - by far the least irritating CMS I've tried so far :p) and I'm having some problems getting my BlogEntry page to validate.

See: http://www.phil.dj/welcome/ and hit the Valid XHTML icon at the bottom.

(Yes, I know my CSS needs a major tidy up (lots of unused or unnecessary duplication/overrides of classes) - at least it validates - this was a port of a design from elsewhere and I only started on this site yesterday so it's a bomb-site at the moment)

It's complaining about the <rdf:RDF> xml tags. I switched to blackcandy, and it still complains, so it's not my template. I've googled on this but I can only largely find technical references simply talking about the rdf tag rather than people with this problem.

I tried validating one of the blog posts on silverstripe.org and got largely the same errors.

Is this simply a limitation of the w3 validator when referring to additional namespaces? Should I change out the rdf xml for the meta equivalents if I'm obsessed over the validator giving me a green light?

Thanks for any help or advice.

Phil