Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Blog Module /

Discuss the Blog Module.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Javascript Parse Error - SS2.4 and BlogModule Date


Go to End


2 Posts   1618 Views

Avatar
edk

Community Member, 39 Posts

23 March 2010 at 5:01pm

Edited: 23/03/2010 5:02pm

Hi,

I know that Ingo announced that there had been an update to the Datetime API in 2.4.

I am based in the U.S and using the Date and the calendar dropdown is rather quirky. The dates displayed in the field are in DD/MM/YYYY format (I would like them to be MM/DD/YYYY), but when I try to save the date as say March 26th 2010, it will throw a "JavaScript Parse Error" in the feedback in CMSMain window.

I am hoping there is a simple Config setting to help solve this? Anyone have any ideas?

Thanks,
Ed

Avatar
sparkalow

Community Member, 8 Posts

8 April 2010 at 6:34am

I have a dirty hack that is getting my by a hump:

calender-setup.js in the thirdparty folder line 5:

I changed to ifFormat : "%m/%d/%Y", // the date format

I suspect it is related to a locale setting in Zend_Date/ Sapphire Date, until someone fixes it or I can dig further this is what I'm going with and hope it does not affect anything else. Currently I only have the blog module in use.