Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Blog Module /

Discuss the Blog Module.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

[Warning] array_key_exists()

Go to End

3 Posts   1610 Views


Community Member, 2 Posts

12 May 2010 at 10:57am

I'm fairly new to silverstripe and I've problem with installation of the blog module.
My silverstripe installation directory is /var/www/silverstripe. I copied blog files into /var/www/silverstripe/blog.
I tried to invoke http://localhost/silverstripe/dev/build?flush=1, which ended successfully as well as new installation with blog copied to the location mentioned before.
The problem is that every time I try to access blog i get:
[Warning] array_key_exists() [function.array-key-exists]: The second argument should be either an array or an object
on line 13 in /var/www/silverstripe/blog/lang/en_GB.php
The contains of this fie begin with:

* English (United Kingdom) language pack
* @package modules: blog
* @subpackage i18n

i18n::include_locale_file('modules: blog', 'en_US');

global $lang;

if(array_key_exists('en_GB', $lang) && is_array($lang['en_GB'])) { // <- this is line 13
$lang['en_GB'] = array_merge($lang['en_US'], $lang['en_GB']);
} else {
$lang['en_GB'] = $lang['en_US'];

This warning disallows me to use blog module - nothing else shows up (besides of callstack of course).
Could somebody help me?
My system is debian lenny.

Sorry for my poor english.


Community Member, 141 Posts

12 May 2010 at 9:08pm


I had a similar problem some time ago.

Change the line:

i18n::include_locale_file('modules: blog', 'en_US'); 
to this
i18n::include_locale_file('blog', 'en_US'); 
and give it another try.

That worked for me.


Community Member, 2 Posts

13 May 2010 at 1:08am

Actually I found out that blog module file on the website is not the recent one, although it's called "trunk". After installation of the newest one (from svn) everything works like a charm :)