Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Blog Module /

Discuss the Blog Module.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Newbie needs help with Blog installation and behaviour in CMS

Go to End

5 Posts   1235 Views


Community Member, 21 Posts

16 May 2010 at 4:10pm

I am a complete notice to SS but I managed to get it installed on

Then tried to install the Blog module. That also seemed to work but there are some strange behaviours I can't work out. I am using SS 2.4 and the last Blog module.

In widgets I have checked Blog Management. So when the site is displayed I see option for

Post a New Entry
Comment Administration
Log Out

when I click Published Site from the CMS.

If I click logout on the Blog page I still two two of those tabs

Post a New Entry
Log Out

If I click Post A New Entry I get the message

Action 'post' isn't allowed on class BlogHolder_Controller

which I guess means not authorised but isn't something a visitor should see at all.

In the CMS under the Blog tab there is an entry which says
Silverstripe Blog Module Successfully Installed but I click this I receive the error

Fatal error: Class 'PopupDateTimeField' not found in /usr/home/liveinsp/domains/ on line 81

The same error occurs if I click the tab below which describes the first Blog posting.

I have no idea what's going on so any pointers really appreciated




Community Member, 96 Posts

17 May 2010 at 6:49am

I think this is caused by the fact that the blog module is not compatible with silverstripe 2.4 yet.


Community Member, 21 Posts

17 May 2010 at 10:29am

That's disappointing. I would like to have Blog so does that mean I have to regress the SS level to use it or is a fix in the works?

How hard is it to de-install the Blog module?


Community Member, 17 Posts

18 May 2010 at 7:25am

It's a pretty easy fix to get it going again.

Check out, make the change they describe there (sans trunk), dev/build?flush=1, refresh admin and no more errors!

Hope this helps.


Community Member, 21 Posts

18 May 2010 at 8:46pm

Didn't work but then I am new to whole SVN thing. Was I supposed to change one line


$fields->addFieldToTab("Root.Content.Main", new PopupDateTimeField("Date", _t("BlogEntry.DT", "Date")),"Content");

to this

$fields->addFieldToTab("Root.Content.Main", $dateField = new DatetimeField("Date", _t("BlogEntry.DT", "Date")),"Content");

or add in the two lines

$dateField->getDateField()->setConfig('showcalendar', true);
$dateField->getTimeField()->setConfig('showdropdown', true);

I added all three lines (one change, two new) did the build which seemed to work but the problem still exists. When you logout of the Blog module, the option to post a blog still shows.

Anything else I should be doing?