Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Blog Module /

Discuss the Blog Module.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Archive Widget no longer working (upgraded to Silverstripe 2.4.0, and trunk r105495)

Go to End

4 Posts   1374 Views


Community Member, 141 Posts

30 May 2010 at 2:43pm

I have successfully upgraded to Silverstripe 2.4.0. However, the Archive Widget no longer works. I upgraded to one one of the daily trunk archives for the blog module (r105495). Does anyone know how to get it working again.

The Tag Cloud widget also doesn't work, but that hasn't worked for a while now. I have searched for methods to get it working again, but have found nothing that works (deleting the widget, rebuilding and reinstalling only causes database trouble). Any ideas on how to get it working again would be welcome.


Community Member, 117 Posts

31 May 2010 at 4:20pm

I've just upgraded to 2.4 and had same problem. Looked in database and for some reason each of the Widgets listed in the Widget table had the Enabled value set to 0. I changed these all to 1 and my widgets re-appeared.


Community Member, 141 Posts

31 May 2010 at 5:19pm

I had a look in the widgets table, and they were enabled. There were some old entries that I deleted. However, I discovered that my theme's tag cloud template was out of date. Fixing that resulted in both widgets suddenly working.

Maybe the archive widget was failing because the error in the tag cloud widget above it screwed things up somehow. No idea really, but it's working now. :-)



Forum Moderator, 435 Posts

1 June 2010 at 12:27am

Have you tried 0.4v?