Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Blog Module /

Discuss the Blog Module.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

After upgrade 2.3.3 to 2.4.1 and blog 0.4 widgets dissapeared

Go to End

3 Posts   1073 Views


Community Member, 68 Posts

16 September 2010 at 12:31am

I just upgraded silverstripe-powered page from 2.3.3 to 2.4.1 and along i have upgraded to 0.4 blog.

After dev/build when i first opened the page, the blogsidebar was there.

Now, it dissapeared, eventhough firebug indicates div id = BlogSideBar, but its empty.

When i logged in to CMS, i could see that there are no widgets added to the blog holder (right side).
By widgets i mean the standard ones, available out-of-box with blog module.

Dragging and dropping them from left to right doesnt work (i only get to select part of the text inside those widgets)
Clicking on the arrow inside of widget doesnt do anything, but firebug's console shows this error coming from ../cms/javascript/WidgetAreaEditor.js:

$("WidgetAreaEditor-" + widgetArea) is null [Break on this error] $('WidgetAreaEditor-'+widgetArea).addWidget(className, widgetArea);

I tried to replicate the error today, but i got:
$("WidgetAreaEditor-" + widgetArea) is null
[Break on this error] </li>

Any hints appreciated as site is live on client's server


Community Member, 1 Post

17 September 2010 at 4:25am

Edited: 17/09/2010 4:25am

I had the same problem and I located it to the template file for WidgetAreaEditor. I don't know exactly where the problem lied but I think it had to do with apaches caches. I edited cms/templates/ and the problem dissapeared. (made change, saved, changed back, saved). It will probably be sufficient to restart apache or touch the file.


Community Member, 68 Posts

17 September 2010 at 4:59am

Diger_s: thanx a lot, it worked for me !

To blog creators - could this tip be copied over to wiki ?