Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Blog Module /

Discuss the Blog Module.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Cannot login as a blogger

Go to End

4 Posts   1230 Views


Community Member, 7 Posts

6 March 2012 at 4:15am

Edited: 06/03/2012 4:15am

I've created a silverstripe (v2.4.7) site based on the olivesunset theme. I've included the blog module (0.2.0) and almost everything seems to work OK. You can see it at

In the backend, under "Security" I have a Security Group called "Bloggers" to which I added a user who has permissions to manage blog entries only. But I cannot login as that limited blogger user. The site responds saying, "I'm sorry, but you can't access that part of the CMS. If you want to log in as someone else, do so below."

I'd really like to fix this problem before I move the site into production. I'm hoping someone here will have some idea what's going wrong.

Optic Blaze

Community Member, 190 Posts

9 March 2012 at 12:31pm

Hi there, i think i have some answers for you.

You probably went to Security->Bloggers->Permissions and then ticked that the users in that group should have access to Blog management. That is 100% correct...but the problem is that when the user tries to log into the site using the "" url silverstripe thinks that he wants to log into the CMS itself, and because you did not give him permission to view the CMS it denies him access. Interestingly enough he is actually loggen in as a user. If you were to click on the blog tab in your site after the "failed login" you should notice in the blog management widget in the sidebar that he/she has the option to add a new entry. Try it should work.

How to fix the problem...

Well first off there are two ways that you can post to the Blog.

(1) is by using BBCODE which uses the the blog page other words not the CMS. This is ok if all the person wants to do is just type text but it is limited in that you cant add hyperlinks nor add images. There are ways to modify the out-of-the-box features but personally i prefer option 2.

(2) using the CMS. In order for you to do this and make sure that your bloggers dont get access to the rest of your site you have to modify your site's security slightly. (a) Go into the site tree -- log into CMS click on Pages Tab and look for the 'earth symbol' (see screen shot 1). Click on it and then select the access tab. Then change the default setting for people who can edit pages to "Administrators" and "Content Authors" if you like dont forget to save and publish! Your site will now only allow Admins and Content authors to edit pages

Then click on the Blog holder (screenshot 2) and modify its access to Administrators, Content Authors and Bloggers and save and publish.

Finally go to the Security--Bloggers--Permissions Tab and make sure you check the 'Access to Pages Section' and publish.

That should then allow your bloggers to log into the CMS and only be able to write blog with images as well as hyperlinks.

Hope it helps

Attached Files

Community Member, 7 Posts

9 March 2012 at 10:21pm

Thanks Optic Blaze, for your detailed instructions. I'm feeling a tad embarrassed that I hadn't noticed my blogger role was actually able to login from the front-end, despite the erroneous error message!

I want my blogger role to be able to add images, so I used your option (2), and your instructions worked perfectly.

Optic Blaze

Community Member, 190 Posts

9 March 2012 at 10:27pm

Glad to hear it works!