Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Blog Module /

Discuss the Blog Module.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Userform v0.5: Issue Adding Fields with SilverStripe 3

Go to End

10 Posts   5446 Views


Community Member, 2 Posts

4 July 2012 at 6:19pm


I am having a problem with the userform module (tried with both version 0.5 and Latest master build from Git) on SilverStripe 3.

When I use userform v0.5 --> nothing happens and cannot even display the page after I set page as a user defined form page.
When I use latest master build that I downloaded from git (04 July 2012) --> it is much better but I cannot add any form field.

When I go to create fields, I get a blank white screen (the URL of this page is /admin/pages/edit/show/108) and nothing happened.
I tried both /dev/build and /admin?flush=all after I installed this module.

One thing I noticed from latested module is that in the configuration file (_config.php) it is referencing FieldEditor.js from Javascript folder.


However, in the actual Javascript folder only have one file - "UserForm.js"
--> I tried to rename UserForm.js to FieldEditor.js but no luck.
also tried to change the path of the file, but again I had no luck. :-(

Could anyone help me to resolve this issue?

Thanks in advance for your help.


Community Member, 5 Posts

29 July 2012 at 6:50am

Edited: 29/07/2012 6:52am

I had the same issues then tried latest 7.7.2012 build

prerelease 3.0.1 rc1

Dev/build then flushed the cache.

It works fine except that when I try to build a contact us form, they are saved in the server but no email is sent to the recepient.


Community Member, 20 Posts

30 July 2012 at 1:35am

I attached the build which works on the SS3 stable. And this is forum for Blog Module :-|


Community Member, 2 Posts

30 July 2012 at 10:26am

@Hattori: thanks for the attached file. I tried this file but it generates the same error. (see attached screenshot for your information please)
and you are right. this is a forum for the blog module indeed. my apologies.


Community Member, 3 Posts

2 August 2012 at 1:49am

I also have this same problem. The userforms module just doesn't work.

Does anyone have any ideas as to what might be causing this?


Forum Moderator, 5523 Posts

2 August 2012 at 9:49pm

Do you get any javascript errors on the page?


Community Member, 3 Posts

2 August 2012 at 11:19pm

I get no javascript errors, I'm using chrome's developer tools. No exceptions appear and there are no php errors either. I have error reporting set to all. Only thing I can think of is to load it up in netbeans and step through it. Also the _config.php is referencing a js file that does not exist. The same one that was mentioned in a previous post. I changed it to UserForms.js which is the only js file in the directory but it had no effect. I am using the latest trunk copy too.



Community Member, 2 Posts

28 April 2013 at 8:48am

Edited: 28/04/2013 8:53am

Frustrated with this issue too.

I am just starting out with Silverstripe and wanted to make use of Userforms. Initially it didn't work and I read a post about installing the HEAD file. I managed to get it going.

Since then, I rebuilt the machine and have tried all manner of installations (include the HEAD file) but cannot create a field in the form. The drop down list box appears, but when I click 'Add', nothing happens. No error on screen and I can go to other tabs without issue.

I've flushed and dev/built until my fingers hurt. I've looked at the composer.json file and also find it is referencing files in the javascript folder that don't exist.

It feels that I'm almost there, but its just not happening.

Any ideas about what might be wrong, or about what I might be able to try..
(from ANYONE!!)


I've just read through the FieldEditor.php file and saw (if I understand the code correctly) that if a field type is not selected, that an error message should be displayed to the user.

I went back and tried to create a form field without defining a type - same result as before (Nothing).. So I'm not even getting an error message.. :(

Go to Top