Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Blog Module /

Discuss the Blog Module.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

empty blog page

Go to End

10 Posts   4333 Views


Community Member, 41 Posts

13 January 2009 at 3:19am


I have installed the blog module successfull with dev/build?flush=1.
But every time I link to the blog pages (blogholder or blogentry) I get a complete empty page (no menus, nothing, no html code inside).
I have tried with 2.3rc2 and some daily builds and with blog 02rc1 and some daily builds, but without success. I work with the theme dreamy3 and tried with blackcandy, too.



Forum Moderator, 4102 Posts

13 January 2009 at 3:41am

If nothing is being output to the browser, it likely means you've got a PHP error. Crank up your error reporting or check your error logs.


Community Member, 41 Posts

13 January 2009 at 4:06am

I have checked them. No error message occurs (not from cms and not from system).
But what I have seen now is, that the blockholder page is shown, when no blog entry exists. After the first entry again nothing.


Community Member, 19 Posts

25 January 2009 at 8:54pm

Edited: 25/01/2009 8:56pm

I am in the same boat as George. I have installed the blog module, and it seems to work fine in the CMS, but when I click the link on the site to go to the blog, it just shows a blank, empty page. No errors, no nothing. I double-checked the error logs on the server to be sure, and the page is not generating any PHP errors. (If it is, they are suppressed somehow.)

I also reverted back to the default BlackCandy theme to see if my theme was the problem. Again, everything is fine on the Web site, except when I click the blog link, I get a blank page. I have tried everything, including modifying the _config.php file in /blog/ and moving /blog/ to various locations (sub-directories in SilverStripe and other things), but to no avail. I feel I’m missing something simple here, but I don’t think it is a PHP error of any kind. I think it is a configuration / file placement problem.


Community Member, 19 Posts

27 January 2009 at 4:19pm

Hi All,

I have been working tirelessly on figuring this out. I installed a test install of SilverStripe (latest version, of course) and was fiddling with it. I managed to learn a few things that may help someone help me, but frankly this is getting pretty ridiculous. I am to the point where I consider writing an entire CMS from scratch to be a more elegant (and much faster) solution. Who do you have to kill to get a little help around here? It seems this is a stupid newbie question that should be answered in a couple sentences. (So I would appreciate no suggestions to go pay $150/hr. to talk on the phone with a SilverStripe support specialist. I'm not here to burn cash. This should be really, really simple.)

I created a fresh install of SilverStripe. Everything was in working order. I applied the blog module, ran /db/build?flush=1, and the blog module works perfectly within the CMS. However, once again, when going to /blog/ nothing appeared.

I did, remarkably, discover that going to /blog/sample-blog-entry/ actually turned up the exemplary blog entry!! Unfortunately, I was not able to discern why it did NOT work at the main /blog/ module page. My suspicion is that there is some kind of problem with the PHP in /blog/code/, but that's a (poorly formed) hypothesis, at best.

Interesting to note, I re-installed SilverStripe over again including the blog module from the get-go, and what actually ended up happening is that the home page of my SilverStripe install ALSO began behaving like the /blog/ module previously (with a completely blank page, and no errors of any kind). The subsequent (About, Contact, example pages) did not encounter this problem. Furthermore, the /blog/ module's main page also continued to misbehave by producing a blank page. However, what is very curious is that if I go to /?stage=Live, everything works fine, but this benefit is not extended to the /blog/ module (i.e. /blog/?stage=Live still produces a blank page).

My guess is that, based on this behavior, the problem is most likely stemming from the /db/build?flush=1 program that, when the blog module is installed, some database corruption occurs, because this problem is isolated to the blog module itself if I install the blog module *after* installing SilverStripe; this problem exists on the SilverStripe root directory if I install SilverStripe and the blog module simultaneously. Does this bring anyone closer to the clues?

As you can see, I have spent many hours (needlessly) diagnosing this problem. I am not sure why it is only happening to a few people, but it is a pain in the ass. If it a configuration issue, the only thing that it could be (according to the SilverStripe installation program) is mod_rewrite, which it can't tell is enabled. I have it installed on my server and SilverStripe works fine, so my assumption is this is not the issue.

Help would be appreciated.


Community Member, 501 Posts

27 January 2009 at 10:33pm

Put a


in your _config.php

It'll show you the exact error.

Also, see if you happen to have any shorttags in <? instead of <?php

perhaps that's causing havoc when it's not enabled?


Community Member, 19 Posts

28 January 2009 at 1:04pm


Thank you for your reply. As per your suggestions, I added the Debug::send_errors_to() command (the command you mentioned is deprecated) to the _config.php file. I also tried adding it to the _config.php file in /blog/ (where the blog module is installed). I also went through all of the /blog/code/ blog module PHP files to ensure that no PHP short tags were used, which they were not.

To my dismay, I have not gotten any error reports whatsoever. The lack of errors is my real problem. I am not a PHP or programming novice -- so far, all of my difficulties with SilverStripe have in some way stemmed from incorrect configuration or knowledge of the structure of SilverStripe. I believe this is another of those instances.

Do you possibly have any other ideas? Thanks again for your reply.


Community Member, 19 Posts

28 January 2009 at 1:55pm

Edited: 28/01/2009 4:00pm

I have done some more digging, and I think that this *may* be related to the database somehow. I have re-run /db/build?flush=1, with no changes, but I have noticed that if I type /blog/anythinghere/, it takes me to the "blog management" page and reports that there are no blog entries. I was able to create another blog entry through this interface, but it still reported that there were no blog entries (although it added a January, 2009 date to the archive on the blog management page). Interestingly, if I type in /blog-entry-title/, I also get a blank page; I know it is *trying* to retrieve the data, because it displays a blank page, as opposed to a "Page not found" page. Does this help at all?

Edit: I have done a lot of sifting through rows in the database using phpMyAdmin, and everything seems to be in order. The structure of the tables and the blog entries seems to be perfectly fine, which means that the blog module is obviously capable of writing to the database without issue. It would make sense that reading would work fine, too, but that isn't necessarily the case. I could have been wrong about it being a database issue, but I still am not sure. Is there a better way to figure this out? Database entries are being read fine by the rest of SilverStripe.

Edit again: Sometime later, I discovered that *this is a problem with* in the /blog/templates/Layout/ directory. If I remove the line <% include BlogSummary %>, then the page displays fine. I will continue working to see what changes are necessary to make this Blog Summary control work properly. I am almost certain (but have not tried it) that this problem is also in /blog/templates/Layout/

Edit #3: I have discovered that the problem is in direct relation to the PEAR BBCode parser. I'm still trying to pinpoint the exact problem, but it seems to be related to the SSHTMLBBCodeParser class.

Go to Top