Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Blog Module /

Discuss the Blog Module.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Archive widget doesn't work

Go to End

22 Posts   6388 Views


Community Member, 37 Posts

29 July 2009 at 1:44pm

Lestatron, your fix worked great for me, thanks.


Community Member, 7 Posts

27 August 2009 at 11:31pm

Ultimate you should probably try to debug the 2) BlogHolder.php function BlogEntries() (Line 199) using echo for $year and $month. See if the url params are correct. And be sure you haven't deleted the sub if and if else which creates date string for the entries query!

Web Designer Perth

Community Member, 49 Posts

22 September 2009 at 1:31pm

bruceb's fix worked for me :)


Community Member, 7 Posts

28 September 2009 at 8:38am

bruceb fix will work until the year number hits 2010. Basically you have to add a new allowed action for every year you want to be able to query with archive widget. So it isn't very nice and solid solution...

Bruce B

Community Member, 164 Posts

28 September 2009 at 11:13am

My fix was not intended to be permanent, just until a new version of the blog module was released. At this stage, I'd probably add '2010' just to be safe. Its a quick fix for those with less confidence in editing multiple files but it does mean you will have to go back to those clients' sites when the new module is released.

Lestatron's fix, however, means that you don't have to go back and update published projects when the new blog version is released.

That raises an issue for another thread - how do people handle subsequent version updates once a project is completed and handed over to the client? Maintenance and upgrades for 12 months built into the original quote?

I should mention that I've added 'SearchForm' to the list of allowed actions in blogholder.php as well - otherwise search doesn't work within the blog.


Community Member, 7 Posts

28 September 2009 at 9:05pm

Yep! bruceb I totally agree with you. I should have written this text in my post, but I'm too lazy.
I added the 'SearchForm' action fix to my solution as well.
Thanks for the hint!

BLU42 Media

Community Member, 71 Posts

4 November 2009 at 5:05am

@lestatron - Great fix - simple yet effective!!


Community Member, 224 Posts

19 November 2009 at 4:44pm

For me the page just refreshes - nothing changes

I downloaded the latest blog module and that one does not save the widgets on the widget tab.

Any other ideas?