Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Blog Module /

Discuss the Blog Module.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

TweetMeme's retweet button - not working, any ideas?

Go to End

4 Posts   3137 Views


Community Member, 3 Posts

30 October 2009 at 1:23pm


I'm trying to use TweetMeme's retweet button ( but for some reason it refuses to show up on any page. I put the<script> code directly into the ss files for blog summary and entry. I know the button code works, I've tried it on a page outside of my SilverStripe install and it shows up just fine.

There are no javascript errors, the link to the .js is definitely correct.. is there some kind of Javascript validation behind the scenes that's causing this javascript to not be processed correctly?

If anyone come across this issue or anything similar before, how did you solve it? Or any ideas at all would be very appreciated..



Community Member, 3 Posts

30 October 2009 at 2:19pm

Still no solution..

After a bit more research I came across a few posts here that kind of related to my problem. I tried putting this line into the where I want the button to show up:

<% require javascript( %>

and added this to _config.php:


but no luck :(


Community Member, 3 Posts

30 October 2009 at 2:20pm

This is the javascript error I get when I tried the above:

Error: uncaught exception: [Exception... "Operation is not supported" code: "9" nsresult: "0x80530009 (NS_ERROR_DOM_NOT_SUPPORTED_ERR)" location: " Line: 1"]


Community Member, 244 Posts

30 October 2009 at 3:06pm

That's because document.write isn't supported with a script XHTML document. I would reccomend just changing your website to use a HTML doctype.