Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Content Editor Discussions /

Forum for content editors and CMS users.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

problem pasting in tables from word


Go to End


3 Posts   2574 Views

Avatar
Guy Van Bael

Community Member, 61 Posts

5 April 2012 at 7:09pm

Edited: 05/04/2012 9:08pm

Hi,

I encountered a problem when pasting in tables from word in de $content-field (tinymce-editor). When pasting, it keeps the formatting from word which causes the table to exceed the content div. I also can't use the "paste as plain text"-option, because then it isn't a table anymore.

Does anyone have a solution?

Thanks,
Guy

Avatar
swaiba

Forum Moderator, 1899 Posts

5 April 2012 at 9:09pm

How about opening the HTML in a popup and pasting the raw HTML in there?

Avatar
Guy Van Bael

Community Member, 61 Posts

7 April 2012 at 1:19am

That's exactly what i did and it keeps the messy html code that word generates.
I found a pretty decent solution though. Just take the table (from Excel) and past it in this website
http://www.shancarter.com/data_converter/

It cleans up the code pretty nicely....

But.... @Microsoft...please let your products generate decent html...

Guy