Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Content Editor Discussions /

Forum for content editors and CMS users.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Java Script Parse error in admin

Go to End

9 Posts   8794 Views


Community Member, 3 Posts

30 April 2009 at 1:25pm

just installed - went fine.
But: now I entered on the home page my Meta Tags: description and Keywords.
clicked save & publish = javascript Parse error pops up - and disappears after a few seconds - but the page never finishes saving.

I have zero modification as of yet [have Blog, forum, Diary and Private messages showing in my top menu on the Published Site],
no widgets inserted yet. But loaded all mods I need before the installation. Ran the flush etc. and everything worked fine.

Am at a loss to why the home page now does not save with the meta tags. Did not even change the text [content] yet on the home page either. No new theme installed yet either - just the generic default theme.

where do I need to make changes to be able to save anything? without the java script parse error? I only was able to stop the saving [after waiting for more than 10 minutes by simply clicking another link in the admin. Checked - and - no, it did not save any meta information.
Help is appreciated.


Community Member, 541 Posts

2 May 2009 at 1:44am

What modules have you installed over default?

Is it just Blog, forum, Diary and Private messages?



Community Member, 16 Posts

6 July 2009 at 1:02pm

I have the same error. Also the site tree keeps getting longer (adding padding?) every time I switch from one page to the next. I have the following modules installed. My page, however, seems to save fine.

- blog
- dataobject manager

Attached Files

Community Member, 37 Posts

5 August 2009 at 12:50pm

I'm having essentially the same problem. Anyone find a solution to this?

John Silver

Community Member, 10 Posts

20 August 2009 at 12:28am

I had the same problem - but in my case it was homegrown. Removing the following line from my php.ini solved it for me.

tidy.clean_output = On


Community Member, 541 Posts

25 August 2009 at 3:50am

I have found I get this error from time to time while clicking "Save and Publish", the only work around I have found is to first click save, then click save and publish after the page has finished saving.

Not sure why this happens, but that generally works for me.

Kim Carson

Community Member, 1 Post

5 February 2010 at 3:55pm

My 2 cents ..

I've added the portnumber (default = 80) in the file : _config.php which resides in dir. : \www\silverstripe-v2.3.5\mysite\.


                        'localhost:80',  <-- added port
                        '', <-- added port

That got rid the parse error
This also "solved" the site tree keeps getting longer issue for me.


Community Member, 11 Posts

16 April 2010 at 5:40pm

I am on version 2.3.6 and experienced the javascript parse error after a fresh install. To fix this, I re-uploaded the cms/javascript folder to the server and overwrote the old one.

Go to Top