I proposed these name changes awhile back and I was told I should start a forum thread for discussion. So here it is.
Isn't content more than just the pages? I think the tab called Site Content in the CMS needs a name change. The only types of content in that section are various types of pages. I propose changing the name from "Site Content" to "Pages". Isn't what's in those other tabs (ie. files, images, comments) also content? And with the ModelAdmin and dataobject_manager module there are lots of custom types of content that can also appear. Safe to say that there are likely going to be lots of content types that will be managed in a CMS, not just the pages themselves.
Related to this, the name "Site Content" at the top of the site tree should probably just say "Site Tree", right? Wouldn't that make more sense? I may seem pedantic about this but I learn a lot from the names people choose for things and with a framework that has very little documentation I think developers could choose better names.