Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Content Editor Discussions /

Forum for content editors and CMS users.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Setting the spell checking language


Go to End


14 Posts   7795 Views

Avatar
Alex S

Community Member, 30 Posts

29 June 2009 at 3:57am

Hey,

Does anyone know how to set the spell checking language for the back-end of the CMS? I looked at "jsparty" > "tiny_mce2" > "plugins" > "spellchecker" > "config.php" but this doesn't seem to specify a language.

I changed "sapphire" > "_config.php" to include "i18n::set_locale('en_GB');" but the only language available for the spell checker is still "English (United States)".

Any ideas?

Alex

Avatar
schellmax

Community Member, 126 Posts

10 July 2009 at 9:44pm

hello,
had the same problem an did some research on it:
the magic happens in CMSMain.php:

$spellcheckLangs = Translatable::get_existing_content_languages();

now, in case you want to set a specific language manually, you can do this through HtmlEditorConfig in _config.php like so (i.e. for german):
HtmlEditorConfig::get('cms')->setOption('spellchecker_languages', '+Deutsch=de');

(the '+' will make it auto-selected)
problem being, the code in CMSMain.php will overwrite what you did in _config.php, so you have to comment out the following line there:
HtmlEditorConfig::get('cms')->setOption('spellchecker_languages', '+' . implode(',', $spellcheckSpec));

hth

Avatar
Platypus

Community Member, 43 Posts

13 July 2009 at 2:42am

Thank you schellmax, is was looking for a working solution, this workaround helped me a lot :-)

Avatar
Ingo

Forum Moderator, 801 Posts

14 July 2009 at 9:11am

This should be fixed in trunk now: http://open.silverstripe.com/changeset/81716

Avatar
schellmax

Community Member, 126 Posts

14 July 2009 at 7:44pm

Edited: 16/07/2009 3:33am

thanks, ingo!

edit: just found there are still other options getting overridden in LeftAndMain.php
i tried the following in my _config.php:

HtmlEditorConfig::get('cms')->removeButtons('tablecontrols');

but it doesn't work, because of this in LeftAndMain.php:
HtmlEditorConfig::get('cms')->addButtonsToLine(3, 'tablecontrols');

commenting this line out once again does the trick, but...
should i file a ticket for this?

edit: there's even more... ticket created: http://open.silverstripe.com/ticket/4390

Avatar
Alex S

Community Member, 30 Posts

19 July 2009 at 11:53pm

Hey,

Thanks for the tip, that works nicely.

Alex

Avatar
AlexBeka

Community Member, 21 Posts

21 August 2009 at 8:08pm

thanks ingo for this fix;

might be interesting for the german-language using of you:
i had a problem with the suggested words and german umlauts ("deutsche Umlaute") and replaced therefore in GoogleSpell.php in function getSuggestions the line

$sug = explode("\t", utf8_encode($this->_unhtmlentities($matches[0][4])));
with
$sug = explode("\t", $this->_unhtmlentities($matches[0][4]));

see also a short german description of this issue there: http://blog.wordpress-deutschland.org/2008/09/08/tinymce-und-die-deutsche-rechtschreibpruefung.html

Avatar
Joeri81

Community Member, 4 Posts

18 February 2010 at 10:36pm

I have the same problem: I am using Silverstripe 2.3.6. I want the spellchecker of TinyMCE to check Dutch spelling. Which code do I have to overwrite?
I am a beginner in PHP so I need some strong directions :P. I tried the soluton above but it didn't work (I probably did something wrong).

My showcase site is located here:
http://www.vauxhallclub.nl/website/site

Go to Top