Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Customising the CMS /

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Tabs missing

Go to End

2 Posts   912 Views


Community Member, 17 Posts

5 May 2010 at 7:40am


I've been recently struggling with tabstrip.{css,js} not loading in one situation.
To reproduce, I need to:
- log in to admin
- click on one of the pages, it's content form loads on the left but tabs are not styled

Once I hit F5 in this state, the page loads in one go with the required styles and JavaScript files.

Unfortunately I'm using a quite old version of SS: 2.3.3. I don't want to upgrade because the whole page is otherwise ready, I have some private fixes etc.

I can't reproduce the issue with a vanilla project. It seems that something I have interferes.
I'm using three plugins:
- userforms 0.2.1
- sfwupload
- dataobject_manager r322

I have tried finding the culprit from both ends, i.e. both tried removing code from my project where the issue is present (didn't get far - it's difficult to remove the plugins from it) and adding code to a vanilla project (I have copied simple code from the problematic project that uses both of the plugins).

I've also looked at various bugs that have been fixed in newer releases that looked relevant, to no avail.

"Requiring" the files unconditionally in LeftAndMain.php doesn't help much - the tabs look better but the page doesn't behave correctly.

Does anyone have any idea on how I could go on about debugging it? Or does anyone have a quick fix (like including all the necessary files unconditionally)?


Community Member, 135 Posts

6 May 2010 at 12:00pm

Sometimes I've seen problems like these in the cms. It turns out my problems were caused by blank lines at the end of my php files.

So what I had to do was go through all the php files in the code folder and delete the blank lines at the end, making sure ?> were the last characters in the file.

I'm not sure if your problem is caused by this, but have a look.