Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Customising the CMS /

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

TinyMCE Plugin


Go to End


3 Posts   1949 Views

Avatar
lemoony

Community Member, 4 Posts

31 March 2011 at 12:37am

Hi,

I tried to install the the following TinyMCE Liststyle-Plugin:

http://policypoint.com/tinymce/docs/plugin_liststyle.html
(Download from: http://policypoint.com/tinymce/docs/plugin_liststyle.html)

I copied the 'liststyle' directory sapphire/thirdparty/tinymce/plugins and I have added

HtmlEditorConfig::get('cms')->enablePlugins('liststyle');
HtmlEditorConfig::get('cms')->addButtonsToLine(2, 'liststyle');

to mysite/_conifg.php, cms/_config.php & sapphire/_config.php - because I wasn't sure which file exactly ;) And, surprisingly, the plugin doesn't work :(

Does anyone have experience with that sort of thing?

Thanks,

lemoony

Avatar
Carbon Crayon

Community Member, 598 Posts

4 April 2011 at 8:59pm

Hi Lemoony,

I always put my TinyMCE plugins outside of hte core, in a folder called 'thirdparty' in the root. I then add this line to my config:

HtmlEditorConfig::get('cms')->enablePlugins(array('PluginName' => '../../../thirdparty/PluginName/editor_plugin.js'));

Not sure if it will help in your case though, but worth a try :)

Aram

www.SSbits.com - Your one stop SilverStripe learning resource

Avatar
muskie9

Community Member, 24 Posts

4 August 2014 at 12:25pm

Any trick to this in SS 3.1.x?????