Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Customising the CMS /

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

User-Specific Content (Client Section)


Go to End


2 Posts   2301 Views

Avatar
Garrett

Community Member, 245 Posts

23 December 2008 at 7:05am

Edited: 23/12/2008 7:07am

Hi,

Similar to this guy [ http://www.silverstripe.org/archive/show/58759 ], I am building a Client Section in a Silverstripe site. Special thanks to *willr* on instructions on overriding the login form. That code works great-- I create a user group for each user of the site, then in the login form I say if NOT in the Administrators group, then serve the page that has a URLSegment equal to the their username minus the "@" symbol. This is all fine, and the redirect works fine.

The problem I am having Now is the the content I need to serve to these Members needs to be HTML. Namely, they are job postings, which I created as a ManyManyComplexTableField because it would give me the the ability to associate many postings to many different users. Ideally, I want the job postings in a table on the right, and then check the boxes of whatever postings I want to appear on the user's page which I have selected in the CMS sidenav.

Now I am again in that terrible conundrum whereby the HTMLEditorField cannot be used in a popup, so I don't know what to do! These job postings have paragraphs and lists and other HTML objects and there's just no way around that.

How can I accomplish this relationship between User Pages and Job Postings and bring this content in dynamically, withOUT making the job postings a ManyManyComplexTableField?

Help!

Thanks,
Garrett

Avatar
Joshuarr

Community Member, 37 Posts

5 February 2010 at 8:21am

Did you ever get this working? I'm having a similar headache at the moment..