Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Customising the CMS /

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Image Upload not working with security group

Go to End

33 Posts   9685 Views


Community Member, 135 Posts

22 December 2009 at 10:18am

I'm getting

parent is null
[Break on this error] parent.document.getElementById('sitet...gName('a')[0].className += ' contents';\n

UploadForm (rule 9)

In the FireBug Console. Don't see any problems in the Net tab.


Community Member, 178 Posts

21 February 2010 at 7:16am

Just adding that I have the same problem running 2.3.5
No problems as admin, but no luck for all cms features. (even declaring them separately)


Community Member, 23 Posts

3 March 2010 at 11:38am

Just adding that I have the same problem running 2.3.6
No problems on my local MAMP and No problems as admin, but no luck for all other group members.


Community Member, 607 Posts

26 March 2010 at 5:22pm

Edited: 26/03/2010 6:10pm

We are having the exact same issue as of today on 2.3.3.

We just updated both PHP and Apache today, with a couple of extensions added for each (including mod_security).

Most definately a server issue based on that.

I'm going to try disabling some of the changes that were made in hope of finding the culprit.



Community Member, 607 Posts

26 March 2010 at 9:04pm

Edited: 26/03/2010 10:36pm

Hi all,

I have recompiled with mod_security2 omitted. No change in behavior. I can easily role back to my last configuration, but I'd rather find the issue, so I'm still back tracking.

Can anyone still having this issue tell me what version of PHP and Apache you are running? We're on PHP 5.2.13 and Apache 2.2.15. This is the major change in the config from what was working a few days ago (PHP 5.2.6 and Apache 2.0.x)

It be good for the SS team to know about any incompatibility issues.



Community Member, 23 Posts

26 March 2010 at 10:24pm

I'm on PHP Version 5.2.12-nmm1 and Apache 2.2 and still the same problem in cms and assets. But I have no problems to upload files in modeladmin.


Community Member, 607 Posts

26 March 2010 at 10:29pm

Edited: 26/03/2010 10:39pm

I've tracked the issue (on my setup anyway).

PHP open_basedir was the problem for me and there have been issues with this setting in the past (check the forum search). But I think those issues have been largely at the installation stage. So this may only be a case of the environment changing post installation for all of us. I also thought that open_basedir problems were weeded out in 2.1.

Kinda makes sense tho. Uploaded files are put into the tmp folder during upload, then moved to their desired location when done. This tmp is sometimes out of the root directory, so the move fails because the script does not have access to that dir.

The fix for this has usually been to make a "tmp" folder in the site root and giving it 777 permissions. I tried this with open_basedir turned on but no luck (probably the first port of call for everyone on shared hosting here). I had to disable open_basedir for now. (I have control over the whole server)

Will be enabling the other stuff I disabled in tracking this down first, to make sure it's not a compound issue. So if anyone knows a fix to the open_basedir problem, fire away. Leaving it off is not a solution.



Community Member, 1 Post

29 April 2010 at 12:57pm

Hi Everyone,

I can confirm that open_basedir fix this problem. It is the only config option I changed and it is now working.