Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Customising the CMS /

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

How to get rid of font-size when adding bullets in CMS?


Go to End


4 Posts   1711 Views

Avatar
rceee

Community Member, 18 Posts

29 August 2009 at 1:08pm

When editing content, if I make an unordered list, I get this code in html:

<li><span style="font-size: 11px;">text here

How can I get rid of this span? Better yet, how can I specify that lists created in the CMS have a custom class assigned, like <li class="myclass">?

Avatar
JMagnusson

Community Member, 29 Posts

29 March 2011 at 7:33am

Edited: 29/03/2011 8:48am

I have the same problem, and I can't find out what's wrong...
Seems to be no answer here or on the tinymce forum :(
/Johan

EDIT: I have the problem in Chrome (10), byt not in IE (8). The text "<li><span style="font-size: 11px;">...<span></li> is just added in Chrome and not in IE!

SOLVED: I don't know what was wrong, but when I installed SS again and copied mysite and themes everything worked.

Avatar
Carbon Crayon

Community Member, 598 Posts

30 March 2011 at 10:07pm

Try adding this to your mysite/_config.php

	HtmlEditorConfig::get('cms')->setOption('convert_fonts_to_spans', false);

Aram

Avatar
JMagnusson

Community Member, 29 Posts

30 March 2011 at 10:17pm

Aram: I tried that one too, because I found an old post about that, but nothing happened.
And I tried to copy the folders cms and sapphire manually from another installation, and that didn´t worked either. I had short of time, so when the new installation worked I left the problem.

Maybe Chrome just had some cache left, because I had no problem in IE.

Thanks /Johan