Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Customising the CMS /

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

static content in sidebar


Go to End


3 Posts   1864 Views

Avatar
chrisio

Community Member, 9 Posts

13 November 2009 at 5:31am

Im really stuck in trying to get some basic static content into the sidebar. It will never change so being able to edit it is not important, I have added some html directly to the sidebar.ss and did a flush but I cant get it to show. I cant belive its this difficult to get a few extra lines to apear in the side bar.

Can anyone help me please

###########content of sidebar.ss################

<div id="Sidebar" class="typography">
	<div class="sidebarBox">
 		<h3>
			Test heading
  		</h3>
  		test body
  		
		<div class="clear"></div>
	
	
	
 		<h3>
			<% control Level(1) %>
				$Title
			<% end_control %>
  		</h3>
  		
  		<ul id="Menu2">
		  	<% control Menu(2) %>
  	    		<% if Children %>
			  	    <li class="$LinkingMode"><a href="$Link" title="Go to the $Title.XML page" class="$LinkingMode levela"><span><em>$MenuTitle.XML</em></span></a>
	  	    	<% else %>
		  			<li><a href="$Link" title="Go to the $Title.XML page" class="$LinkingMode levela"><span><em>$MenuTitle.XML</em></span></a>
				<% end_if %>	  
	  		
	  			<% if LinkOrSection = section %>
	  				<% if Children %>
						<ul class="sub">
							<li>
								<ul class="roundWhite">
									<% control Children %>
										<li><a href="$Link" title="Go to the $Title.XML page" class="$LinkingMode levelb"><span><em>$MenuTitle.XML</em></span></a></li>
									<% end_control %>
								</ul>
							</li>
						</ul>
			 		 <% end_if %>
				<% end_if %> 
			</li> 
  			<% end_control %>
  		</ul>
		<div class="clear"></div>
	</div>
	<div class="sidebarBottom"></div>
</div>
  

Avatar
Willr

Forum Moderator, 5523 Posts

13 November 2009 at 3:15pm

Is your main template even including this file?

The default theme has a <% if Menu(2) %> round it so it will only include the sidebar if there is a menu 2. If your theme has copied the default theme then you will need to remove the <% if Menu(2) %>s that are through out the page.ss template file.

Avatar
chrisio

Community Member, 9 Posts

14 November 2009 at 9:26am

I got it to work by modifying the page.ss which then made it rebuild the cache. Strange thing is, is that I thought by doing the flush all command I would clear the cache.

Nevermind its in place now and alls well in the world!

Chris